BMW Luxury Touring Community banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just bought '05 1200lt, after few days I found out that my Right front speaker shuts off after few min of playing, Did any of you had something similar ? I did clean all the connectors and it didn't help. Is that could be a radio problem ?
Thank you
 

·
Registered
Joined
·
338 Posts
You have 4 speakers on the bike--if only one gives you problem, it is likely that connection to that speaker, broken wire or the speaker it;s self has something loose inside.
 

·
Registered
Joined
·
1,334 Posts
Then most likely its the amp in the stereo. Many of these have taken a crap, including mine. Mine at first was one speaker, then one side, then one on the other side, then the back. Would have been a suedo-quad if I could have gotten them all to do it at the same time. :) Some have sent theirs off to a place to have the board replaced. (@$400. Others, which I'm planning on doing, have installed a Jensen marine radio for @$200 that is waterproof, has ipod hookup, and can have a sirius/xm hookup. The only downfall for this setup is the handlebar controls don't work with it, which really doesn't bother me as the unit is sitting there right in front of you. For about the last three years I've just been using my Creative Zen mp3 player with some Sony earbuds, which sounds real nice, but I miss not having the external option. Do a search for Jensen, and several threads will pop up from guys who have already put them in.
 

·
Registered
Joined
·
4 Posts
hi My r/h front speaker gave up the ghost last month, it came on then of, found to be a BROKEN WIRE IN THE SPEAKER,Does anyone know the size of the speaker. :wave
 

·
Registered
Joined
·
576 Posts
5.25" round speaker. I bought 4 for $80. Make sure they're not paper cones, but that's pretty easy to do these days.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top