BMW Luxury Touring Community banner

1 - 17 of 17 Posts

·
Registered
Joined
·
130 Posts
Discussion Starter #1
I'm having problems with reception on the FM band on the LT.

There is no problem with the AM band and the CD player is working fine. It's just the FM. Nothing but a bunch of racket.

I've taken the antenna off and reseated it but that didn't help.

Hardly every use it but would like for it to work.

Any ideas what the problem is and how to fix it?

Roger
 

·
Registered
Joined
·
3,525 Posts
Radio

Hi Roger
Normally the problem is in the antenna.

The spring loaded portion on the bottom of the mast get's off center and grounds out in the housing...

I put a small piece of heat shrink tubing about 3/8" long on the spring portion with the contact just barely sticking out. Then re-assembled the antenna carefully. This fixed mine... YMMV

If you can't get your's to work let me know and I'll email you a pic of what I did..I'll have to take it back apart to take the pic but no big deal..

Good Luck


John
 

·
Registered
Joined
·
740 Posts
Are you also running an XM or Sirius sat radio? If a sat radio is on and is either using an inline FM modulator especially, or even an internal FM transmitter allowing it to play into your sound system, it will tend to overpower the entire range of FM radio frequencies sometimes shutting out even local stations.
 

·
Registered
Joined
·
130 Posts
Discussion Starter #4
I hope I understand what you are saying. I'll give it a try but get ready to sent pic if you can.

Thanks
Roger
 

·
Registered
Joined
·
3,525 Posts
Pictures

Here's a couple of pics. Should make it all clear..

Good Luck

John
 

Attachments

·
Registered
Joined
·
36 Posts
RBDS on?

I had problems with the RBDS function of the radio and had to shut it off.

RBDS= Radio Broadcast Data System

you can shut it off by pressing The FM button for longer than 2 seconds, then the current status is displayed, press the FM key again to toggle it on or off.

Paul
 

·
Premium Member
Joined
·
3,549 Posts
Try the wx radio. It is AM and uses the FM antenna.
Bob
 

·
Registered
Joined
·
130 Posts
Discussion Starter #9
I think I see the problem from your pictures. The spring on mine is not near that far out.

Thanks for the pictures.

Roger
 

·
Premium Member
Joined
·
3,549 Posts
Unless you live on top of a WX station xmit site, it should indicate your antenna is working fine.

I think wx is around 162 Mhz, and FM ends around 107 Mhz.

Bob
 

·
Registered
Joined
·
206 Posts
FM Reception Fix

I had the same problem. Used some of th elist member's suggestions to drill out the housing but to not avail. It wound up to be the spring. If you push the antenna all the way down into the housing then tighten the nut, it seems the spring contacts the ground (side) and cuts the reception out. In the garage, I turned the radio on and tuned into a weak FM station. While listening, I pushed the antenna in just enough to get good reception then tightened the nut while holding it in place. If I remove the antenna for any reason, I use the same process when I put it back on.

Hey, it worked for me.
 

·
Registered
Joined
·
130 Posts
Discussion Starter #13
I did the shrink tub thing and it still doesn't work. I guess if I want it to work I will need to take it to a dealer. :-(
 

·
Premium Member
Joined
·
3,549 Posts
Since you are getting wx station(s), I think that indicates your antenna is fine.

To verify this, take the antenna off, and try receiving a wx station.

bob
 

·
Registered
Joined
·
130 Posts
Discussion Starter #16
BecketMa said:
Since you are getting wx station(s), I think that indicates your antenna is fine.

To verify this, take the antenna off, and try receiving a wx station.

bob
That makes sense. I'll give that a try and see what happens.

Roger
 

·
Registered
Joined
·
35 Posts
I have just purchased a 2001 LT and have poor reception on the radio.
After searching the board I found this thread, sure enough I took the aerial/antenna off, the spring was well and truly monkeyed up! :(

So two questions really;
Can you get the spring on its own?
Has anyone come up with a better solution than this?

Thanks in advance! ;)
 
1 - 17 of 17 Posts
Top