BMW Luxury Touring Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
260 Posts
Discussion Starter #1
Anyone install a Firestik on an LT hooked up to the C.B.? Seems always a grounding problem with the BMW C.B. antenna system. Thanks Tim :
 

·
Registered
Joined
·
5,408 Posts
roadking04 said:
Anyone install a Firestik on an LT hooked up to the C.B.? Seems always a grounding problem with the BMW C.B. antenna system. Thanks Tim :
No fFirestik experience, but what's the issue(s) with the BMW antenna grounding? I just installed one on my R12RT, and the only "problem" was the 49-gazillion grounding connections required to install the grounding harness.
 

·
Registered
Joined
·
260 Posts
Discussion Starter #3
The problem I am having is works great receiving and transmitting when motor off but when running can still receive but transmitting my fellow riders say cant understand me.
 

·
Registered
Joined
·
5,408 Posts
roadking04 said:
The problem I am having is works great receiving and transmitting when motor off but when running can still receive but transmitting my fellow riders say cant understand me.
A couple more Qs --

Do you have the BMW grounding harness installed (looks like a bunch of snakes tied together -- grounds at 4-5 places around the chassis).

Have you verified that where the antenna bolts to the bracket, there is no short to the bracket? On my RT (same antenna, I believe), there is a white plastic ring which concentrically locates the antenna base while also isolating the base from the bracket.

What do your friends say your transmissions sound like? Electrical noise overlaid over your transmission, effectively drowning it out? Slurred speech? Reduced voice volume to the point that your words are unintelligible?
 

·
Registered
Joined
·
260 Posts
Discussion Starter #5
Cb was working fine when I purchase the new lower BMW headset cords. Now dont . Yes I checked all the many grounds but did not check the base of the antenna for corrosion. Friends say sounds like electrical noise.
 

·
Registered
Joined
·
2,268 Posts
For what it's worth I have an old Firestik CB antenna installed on a home made bracket on my '05 LT. Works great and was cost effective since I already had the antenna and scrap metal that I used to make the bracket lying around the workshop. However, I too had an issue with noise when transmitting on my CB. Receiving worked just fine but my transmission was washed out with lots of noise and a high pitched squeal. The solution that I found after about a year of experimenting was to use an RF choke on both the antenna line and another on the power line to the radio. Here's the Radio Shack part number that I used; RF Choke Catalog #: 273-104. It's a 2 piece torroid and so is very easy to install. Hope this helps.
 

·
Registered
Joined
·
260 Posts
Discussion Starter #7
Lynn, Thanks I went to Radio-Shak and picked up set to try. Any particular way to wrap wires?

Thanks Tim
 

·
Cat Herder
Joined
·
5,852 Posts
This goes into the FWIW category: *I* could never see and hence never trusted thee 'groundless' antenna designs.It just goes against everything I have learned AND EXPERIENCED.

I know I will get "But they provide almost perfect SWR even without grounding", Quite frankly there are a few other devices that do the same: e.g. resistors and nobody has the idea of calling a resistor an antenna.

But then weirder things have been 'marketed'.

Bottom line: ESPECIALLY on low frequencies like CB you just can't get around proper grounding AND proper RF counterweights, which in itself is a problem on a motorcycle, especially on a plastic bike like the LT.
 

·
Registered
Joined
·
2,268 Posts
roadking04 said:
Lynn, Thanks I went to Radio-Shak and picked up set to try. Any particular way to wrap wires?

Thanks Tim
Nothing special. I think I got about 4 turns on each side of the toroid. As I recall there's a brief diagram included with the product which should give adequate instruction. Good luck.
 

·
Registered
Joined
·
2,916 Posts
roadking04 said:
Anyone install a Firestik on an LT hooked up to the C.B.? Seems always a grounding problem with the BMW C.B. antenna system. Thanks Tim :
Got one on the RT and LT both work great. Also bought the splitter, so only have one antenna for the CB and radio.
 
1 - 10 of 10 Posts
Top