BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Just an update for those working with me to get my 01 LT back on the road after nearly 4 years. After going back in, injectors done (mr injector), checking all tank internal connections, replacing fuel pressure regulator, other odds and ends, she fired right up. I think the regulator was the culprit but will never know for sure and now it doesn’t really matter. All that’s left is bleed the brakes (new spieglers), button up the Tupperware, give her a good bath, and hit the road. Thanks all, for helping along the way. Great group!
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,246 Posts
That is great news Jim, glad to hear you got her going again. Now enjoy her!
 

·
Registered
Joined
·
329 Posts
Jim:
Good for you! Enjoy the ride. If you have a winter slow time I’d advise replacing the clutch slave cylinder before it fails and trashes your clutch. Ask me how I know!
 

·
Registered
Joined
·
13 Posts
Hi Jim
I see you are a neighbor. I'm in Lawrenceville GA too.
Just got my first LT a couple weeks ago and still learning about it.
I also have an R11RT and a K75.
Larry
 

·
Registered
Joined
·
689 Posts
Hi Jim

I see you are a neighbor. I'm in Lawrenceville GA too.

Just got my first LT a couple weeks ago and still learning about it.

I also have an R11RT and a K75.

Larry
Definitely a small world. I'm in Kennesaw.
 

·
Registered
Joined
·
4,355 Posts
Sugar Hill here, let me know if you need any help.
 
1 - 6 of 6 Posts
Top