BMW Luxury Touring Community banner
21 - 40 of 67 Posts

·
Registered
Joined
·
854 Posts
My beemer brothers, here is an email I got from BMW Support:



Steffen Kraft (BMW Motorrad Connected)

09.06.2021, 17:57 OESZ

Dear Fernando,



Thank you for your e-mail.



In our view the problems mentioned are probably caused by the energy-saving modes of your mobile phone (see https://dontkillmyapp.com). Please note that some individual settings will be resetted in case of an update of Android. Please make shure, that the settings are made correctly.



Then check



- that the app has permanently access to your location (Settings > Location > Always).

- that the app is allowed to run in background (Settings > Apps > Connected (Motorrad) > Battery > Allow Background Activity)



If a change in the settings of your mobile were necessary please start the app again.



Finally we ask you to reset the Connectivity/TFT display. Call up the >Settings< menu. Select >Reset all< and confirm.



There are two videos which may be helpful:



- https://www.youtube.com/watch?v=KjTz65oFJ7c

- https://www.youtube.com/watch?v=UJ3o2dI8zDA



Kind Regards,

Steffen Kraft


If indeed this trouble-shooting perspective is correct, then either BMW will have to convince Samsung to adapt their OS protocol to the operations of the BMW Connected app, or, BMW will have to figure out software codes to override the Samsumg OS traits causing the malfunctions on the BMW app...

At any rate, if this is indeed the problems, surely it is a non-compatibility technological issues of magnitudes well above my intelligence.
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #22 ·
@wethead This is the standard letter I got weeks ago, its on the other thread. They obviously have a machine sending out standard emails. If what is on my video is showing the issues you have may I suggest you reply to them with a link to the video. I sent mine a while ago. We need to BOMB them with hard evidence, I have applied all the dontkillmyapp switches so its not them.

Its not Samsung either, my Sena still works perfectly with my updated phone, my Sony headset works perfectly etc.

Its the TFT that is breaking Bluetooth, I am convinced of it.
 

·
Registered
Joined
·
159 Posts
Another day, another test ride - I have a Sena SC1 built in to my Schuberth helmet. Started the ride with dedicated iPhone SE paired to the TFT, TFT paired to the Sena as "mobile phone", my iPhone 11 Pro Max paired to the Sena as "second mobile phone" (in case of incoming calls that I need to receive, nobody has the number of the "bike" iPhone), Sena handlebar remote also paired to the Sena.

I put in a route to Dick Lovett's in Bristol, started up and waited for everything to connect and off I went - all working absolutely fine, maps stayed up, voice directions coming through OK, until just coming up to the M5 turnoff I said "Hey Siri" into my headset - thinking that this would activate Siri on my "second mobile phone", since the TFT "phone" knows nothing about Siri??- is that a rash assumption? In any event I had set Siri not to respond to anything on the bike phone so she shouldn't have responded anyway.

Not only did Siri not respond (or if she did I couldn't hear her), but from then on I had no voice directions OR turn by turn directions, although the maps stayed on and showed my route as a blue line. So one or more Bluetooth connections had clearly broken.

Next test I guess will be without the "second mobile phone", although that is a serious loss of functionality as far as I am concerned.
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #24 ·
On one of my tests. I had:

Bike phone to TFT for phone only
Personal phone to Sena for audio, no phone

The TFT broke the Sena to Personal phone

I tried TFT to Sena as GPS and Personal phone to Sena for phone and audio

The TFT broke the Sena to Personal phone.

The TFT has Super Powers.
 

·
Registered
Joined
·
854 Posts
@DavidMcK

Here ya go...will they listen?
The following was my response to their formatted tech support boolsheet


I think you are unaware that many consumers including myself have taken care of the 'stop-app running by Samsung OS'.

Assuming everyone of the forum is wrong and you are right: you need to figure out a way to override the Samsung OS protocol such that the BMW Connected app will not be affected, or, you can work it out with Samsung such that they update to nullify what you claim is their fault as to why the BMW app cuts out. The latter suggestion I don't have much faith in. But you could work it out with Samsung so they give you a code trigger to avoid their culprit cause for the malfunction of the TFT (BMW connected app)

You need to watch this video below:

 

·
Registered
Joined
·
854 Posts
In my darkest most skeptical self: I can't believe BMW did not know about the TFT malfunctions. I can't really imagine designing this system and not testing for connect and re-connect after a stop. I ain't no electronic engineer and simple logic would motivate me to test the system for connectivity under different conditions...no, I think they knew; but the marketeers (the guys who think 'profits' in Corps) dominate over engineering design and creativity, otherwise we wouldn't be having so many recalls in modern manufacturing.

Corporations are giant inanimate entities whose fundamental motivation is profit. I don't trust any of them as they operate with an impersonal demeanor and objectify their data disconcerned with customers utilization. When they work on ergonomics its is to out-do the competition, not because they are concerned with you as a user.

Now, there are many BMW apostles out there (as I called them). Brand apostles who swear allegiance to Brands--they are in all facets of motorcycling manufacturing. These folks will believe the antithesis of my feeling expressed herein. Its ok with me if you don't agree--humans have been expressing 'faith' toward an external entity since the beginnings of time. Faith in BMW is just as well.

if by any chance a BMW person reads this forum here is my message to you: FIX THIS FLOCKING THING!
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #28 ·
@wethead I am pretty sure its the TFT, on one of my tests I had the following.

Sena SRL to TFT as Helmet, no phone connected to bike.
Sena SRL to My Personal phone for music.

So the TFT had no phone attached, it was simply connected to my Sena through the helmet connection.

When I switched on the bike the TFT broke the connection between my Sena and my personal phone. Simply having the Sena connected to the TFT broke the Bluetooth connection.

Hard to believe but there ya go. Don't forget when I started this thread all was working for me apart from some disconnection with the Maps. When I got the TFT update, everything broke.

If I had to guess I think the bikes left the factory with a working system (maybe the maps were flaky). Then they send out an emergency update which had to be installed before the bikes were given to buyers, which broke Bluetooth but maybe helped the Maps. I was lucky to have my bike with the original software and Stop/Starting music worked for me until I got the TFT update and my phone was updated.
 

·
Registered
'21 R1250RT
Joined
·
158 Posts
When I switched on the bike the TFT broke the connection between my Sena and my personal phone. Simply having the Sena connected to the TFT broke the Bluetooth connection.
Could you confirm that the TFT is a lower ranked connection to your Sena compared to the phone? Have you got any information as to how your Sena prioritises connections by type? Could it be that your TFT is higher priority so it boots the lower priority phone?
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #30 ·
Could you confirm that the TFT is a lower ranked connection to your Sena compared to the phone? Have you got any information as to how your Sena prioritises connections by type? Could it be that your TFT is higher priority so it boots the lower priority phone?
Don't know how to check that, for me, the bottom line is "It worked" until I got an update and then "It broke". In all the fiddling/testing I have done, one thing I can be confident of is that when I switch on the bike, what was working will be broken.

I can't fix it and I don't think any of us will, BMW Motorrad have to fix the TFT software.
 

·
Registered
'21 R1250RT
Joined
·
158 Posts
Don't know how to check that
That is fair enough. The point I am trying to make that it is possible the way Sena handles things could be the reason for dropping the phone connection.

You could always try involving Sena in this mess :D Given the success you are having communicating with BMW, you could be on a roll here (y)
 

·
Registered
Joined
·
321 Posts
Discussion Starter · #32 ·
I am happy the Sena is behaving itself. When I tested the Sena disconnected from the tft playing music it was perfect. However when connected to the tft things broke. I never had to re-pair the Sena. But I had to re-pair the phone to the tft.
 

·
Registered
Joined
·
854 Posts
I am happy the Sena is behaving itself. When I tested the Sena disconnected from the tft playing music it was perfect. However when connected to the tft things broke. I never had to re-pair the Sena. But I had to re-pair the phone to the tft.
I think you are right about this DavidMcK, it ain't the Sena.
The TFT will not allow the Sena to be paired independently of any other source. That was the same story on the Goldwing.

When I was running a GarminV and a VI, I could pair the GPS to the Sena and phone1 to the phone and it worked...not going through the bike though. It the TFT kaka that is messing things up
 

·
Registered
Joined
·
68 Posts
I am happy the Sena is behaving itself. When I tested the Sena disconnected from the tft playing music it was perfect. However when connected to the tft things broke. I never had to re-pair the Sena. But I had to re-pair the phone to the tft.
David, woohoo I have fixed the problem with, nav, music, phone after 5500k riding. All is working perfectly just the same as my 2014RT, I deleted all of the pairing to the TFT, now everything goes only to my ZumoXT !

Love the 2021RT everything else is better than expected, I'm happy to wait until BMW gets their act together to make my SRL headset and iPhone 12 Pro work with the TFT.
 

·
Registered
Joined
·
854 Posts
David, woohoo I have fixed the problem with, nav, music, phone after 5500k riding. All is working perfectly just the same as my 2014RT, I deleted all of the pairing to the TFT, now everything goes only to my ZumoXT !

I agree this would definitely fix the problem. However, didn't you at least cried a little when you had to ditch another 500 bucks to get something you already paid for?
 

·
Registered
Joined
·
1 Posts
When I was navigating the MABDR on my 09 GSA I did not have cell signal in some sections. Paper maps, Garmin onreach iPhone app & Garmin XT showed the way correctly. Having so much functionality tied to one TFT screen the size of Garmin XT is uncomfortable. What if a sw glitch brings down the entire system. In remote areas reliance on too much tech could be a bad thing.
 

·
Registered
Joined
·
854 Posts
My guess is that even if Mother Beema fixes this thing, I might prefer to travel with a Zumo. I guess old habits die hard...or don't die I should say.
 

·
Premium Member
Joined
·
5,678 Posts
I am still waiting for my RT, and from all that I have been reading, I am very glad that I held onto my Nav V! I have the car-mount for it as well, which will be very easy to adapt to the handle bar!
 

·
Registered
Joined
·
27 Posts
Let me start by saying that I am disappointed in the overall performance of the system. It does not seem like everything is functioning like promised. Now, I do like the idea. It is nice to have all the things you need on one screen. I started this process by using an Pixel 4a5G that my wife dropped in water and thereby ruined the SIM card reader. I had it going well just using it as my BMW phone, until the GPS crapped out on me. So I started using my working Pixel 4a5G, which required me to take off the case. It was working great, nav, maps, music, until I stopped for gas turned off my bike and could never get the wireless connection on my bike to work again. So no map. However, the directions worked. I took it to my dealership and guess what, my phone connects to other RTs and the sales manager could connect to my bike using his iPhone, but I could never get my wireless to connect again. And by the way, I emailed BMW and after the first response asking for some information, nothing back from them. And I emailed for updates numerous times.

So I got an old iPhone 7 from a friend, updated the OS, and downloaded the app. This seemed to work OK for the wireless. Connected my Cardo headset and we were off to the races. Oh, until it decided that while I could control the music (downloaded Pandora playlists) from the bike, no sound coming into my headset. Until it decided to change its mind and start letting me listen to the music. So I might just disconnect the headset from the bike and use the cardo connection directly to the phone to listen to music. At least my phone fits now.....and yes, I put on a wireless power adapter on the phone so I don't have to deal with cores.

Bottomline, new idea but the implementation needs a lot of work. The good thing is that this is software, which I hope that BMW continues to update.
 
21 - 40 of 67 Posts
Top