BMW Luxury Touring Community banner
1 - 4 of 4 Posts

·
Registered
Joined
·
918 Posts
Discussion Starter · #1 ·
...so I close the throttle to upshit, then when I open the throttle again: nothing....no power.
This has happened to me 3 times now. It appears to occur at random times.

I have a friend who also has the same experience with a GS; he claims is the 'quick-shifter'

Anyone having the same issue?
Anyone know how to fix it?
 

·
Premium Member
Joined
·
126 Posts
If you are using the "quick shifter" you shouldn't be closing the throttle - you just keep it pinned and shift without using the clutch.
Look at page 183/184/185 in owners manual for info on the "Gear Shift Assistant Pro" as BMW calls it.

I personally haven't experienced what you mention and I have a 2016 GSA and 2021 RT, both having the Gear Shift Assistant Pro.

Font Number Paper Document Parallel


Font Publication Parallel Paper Document
Font Rectangle Number Parallel Pattern
 
  • Like
Reactions: glospolbiker_9445

·
Registered
2022 R1250RT Racing Blue
Joined
·
22 Posts
Had something similar on my 17 RT. It would cut out, and wouldn’t respond until I cycled power. Turned out to be a faulty throttle position sensor.
 

·
Registered
'21 R1250RT
Joined
·
442 Posts
I close the throttle to upshit, then when I open the throttle again: nothing....no power.
Check the tiny connectors on the throttle side, especially the throttle one. I had an intermittent no fire issue due to the other connector on the right grip. Maybe yours isn't pushed in all the way and therefore the pins are not making proper contact. Worth checking...
 
1 - 4 of 4 Posts
Top