BMW Luxury Touring Community banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
First time to get my fingernails really dirty! Changed the oil, FD fluid, transmission fluid & radiator fluid. Put in a HID low beam and added PIAA 1100x. Put some Hyper lites on the back! Here is the problem, when I start the engine it revs up around 4000 rpms. I can get it to go to 3000 but have to work hard on the throttle. Any thoughts of what I did wrong? :confused:
 

·
Registered
Joined
·
3,525 Posts
Check throttle cables.

John
 

·
Registered
Joined
·
322 Posts
Did you disconnect the battery when you were doing the lighting? If so you need to re-teach the throttle position.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Cable was pulled tight, wiggled it and now she purred at 1000 rpms! Thanks for the help! Now to put on all the tupperware and start riding!!
 

·
Premium Member
Joined
·
7,795 Posts
disco battery
wait about 5 minutes
reconnect battery
turn igniton to "ON" and "kill switch" to RUN.

Immediately turn the throttle from idle to full throttle at least 3 times in 10 seconds or less.

Turn ignition OFF

Turn ignition ON and start bike.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,246 Posts
You know every one makes a big deal on the TPS reset but I have found it not to be necessary. I forgot to do it when I buttoned it back up after the clutch job (battery off for two weeks) and I had nary a stumble at all. The only driveability problem I had was the one fuel injector connector I failed to fully latch in place.
 

·
Old Slow Guy in A Fast Car
Joined
·
8,601 Posts
jzeiler said:
You know every one makes a big deal on the TPS reset but I have found it not to be necessary. I forgot to do it when I buttoned it back up after the clutch job (battery off for two weeks) and I had nary a stumble at all. The only driveability problem I had was the one fuel injector connector I failed to fully latch in place.
John that's only because you are SO GOOD that the bike if afraid not to run good after you have worked on it. ;)
 

·
Registered
Joined
·
322 Posts
Mine eventually settles in, but the idle tends to run high for a while - around 1400 RPM.
 
1 - 9 of 9 Posts
Top