BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
As I posted earlier, I just purchased the latest version of the Navigator IV.
I found the display screen very, very dim and suffering from debilitating glare. I called my dealer who told me to increase the brightness using the tool menu.

With the Navigator IV installed in the K1600, it is turned on, go into tools>Display>Brightness. The unit showed brightness setting at '10' (out of 100). There is a (-) button and a (+) button. I pressed the plus button but nothing happened. I pressed the minus button and nothing happened. I checked some other screens elsewhere and everything worked fine but the DISPLAY menu never functioned at all. I started the engine and tried the routine again: same results of inactive buttons in the DISPLAY menu.

I called the dealer and conveyed the problem status. I was told to bring it on in for either a correction or swapping it out for a new one. At the dealer, they tried the identical unit to mine that they had available. To their amazement, their Navigator IV failed to work in the DISPLAY menu and showed only a '10' brightness setting, just as mine did! We next tried mine and they verified the same identical condition. The entire crew at the dealer tried to figure out what was happening but no one could figure this conundrum out. They decided to contact BMW directly on Monday.

I will post an update when I learn further details. BTW, if you hand hold the Navigator IV so that it runs on its internal battery, the DISPLAY setting works properly and can be set to any brightness. But when it is plugged in and mounted in the bike (any K1600 bike), it fails to work. :confused:
If anyone else has figured this condition out, please post.
 

·
Premium Member
Joined
·
416 Posts
Paging JimE to the white courtesy phone....

(or go back and read the last few posts of your last thread :wave )

Tom
 

·
Registered
Joined
·
616 Posts
At the risk of going to this well once too often...

There is nothing wrong with your Navigator. Do not attempt to adjust your display. We will control the brightness....​
 

·
Registered
Joined
·
616 Posts
From the K1600GTL Rider's Manual, in the "Navigation device" section:

Here's how it senses the ambient light:

In the sun, it will put the Nav brightness at 100%. You can satisfy yourself that the sensor is working by (in the garage) putting your hand over the sensor and watching it dim the panel and the Nav display. Then remove your hand and watch it increase the brightness (assuming your garage isn't dark...but you get the idea).
 
1 - 4 of 4 Posts
Top