BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
I recently became a sucker..er... "customer" of DICE Electronics (Audiovox) DUO-100-BMW Silverline iPod adapter unit for my 2005 K1200LT. Having had a '99 LT and a older DICE unit with success (playback AND Display scrolling), I was expecting the same level of achievement with this install. I am using a 4th generation Nano with the latest iOS.

No DICE (haha..pun intended). My iPod playback is ok, controls are ok, yet I have NO display other than the "CD 01, TRACK 01" on the instrument panel. As another member experienced on here, I can scroll through the CD1..2...3..etc., but there is no text or way of turning on the text function. I tried everything in these forums and what I can find online, and still cannot get the darn display to work.

I even purchased the SCC1 Sirius Receiver to connect to the DICE unit. Guess what? Of course it doesn't work. :rolleyes:

Since DICE is now owned by Audiovox, I was hoping for a better experience. Oh well. I checked online, verified the DUO firmware was up to date, and noticed that the Audiovox website does not have the K1200LT as being compatible with this unit. :wtf: Just about every other retailer out there that sells this thing has the K1200LT as a compatible vehicle. I purchased it from one of these retailers.

In doing more research, I found the Neo ProLink 2.0 POD2BMWV1, which claims to work with the '05 K1200LT on www.neocaraudio.com. Funny thing though, it looks EXACTLY like my DICE DUO unit, only with a NEO brand name on it. Could it be that Audiovox/DICE private labeled the product to NEO?

I have searched threads in here going back to 2006 and there are varying levels of success performing this upgrade. My question is, has anyone had RECENT success with any latest solution to get sound AND scrolling text coming through the stock '05 K1200LT setup? I am not interested in the Jenson setup....yet...LOL

If so, what is your secret? Pretty Please.....
:brick:
 

·
Registered
Joined
·
40 Posts
Not to hijack your thread but what model DICE did you have on your '99 that worked? No volume isssues?
 

·
Registered
Joined
·
93 Posts
Discussion Starter #3
I wish I could remember. It was one of the first models DICE came out with for the K1200LT. It had a square black case, and two double DIP switches. I had no volume issues, and i had scrolling text. The Only problem I had at times was that it locked up if I tried to scroll through the songs too fast.
 

·
Registered
Joined
·
1 Posts
I was plunging through these threads yesterday and think I remember seeing a post about the DICE not working in the later models K1200 (think 2004 and up)... not sure though. Poke around and see if you might find that posting thread.


I have a Y2K model and am looking for a DICE unit. Would you be interested in selling it?
Let me know....

-Ed
 

·
Premium Member
Joined
·
323 Posts
The Neo ProLink 2.0 POD2BMWV1 from Audiovox worked perfectly on the 2002 K1200LT display and all, I've been enjoying it for several weeks now. I remember reading post of users with newer model LT's having issues though. I wonder if something in the CD harness changed in 2005? I can take pictures of my harness if you think it will help you jerry rig the connection but likely the change is in the head and not the connection. I posted my experience over here ...
 

·
Registered
Joined
·
495 Posts
Now I am currious. I tried the CD / Dice replacement and it wouldnt work. They refunded my money and now I am reading two years later that there actually is a 99 LT out there that had a successful Dice install???

Please Explain.

Thanks

Steve A


LJSMITH1 said:
I recently became a sucker..er... "customer" of DICE Electronics (Audiovox) DUO-100-BMW Silverline iPod adapter unit for my 2005 K1200LT. Having had a '99 LT and a older DICE unit with success (playback AND Display scrolling), I was expecting the same level of achievement with this install. I am using a 4th generation Nano with the latest iOS.

No DICE (haha..pun intended). My iPod playback is ok, controls are ok, yet I have NO display other than the "CD 01, TRACK 01" on the instrument panel. As another member experienced on here, I can scroll through the CD1..2...3..etc., but there is no text or way of turning on the text function. I tried everything in these forums and what I can find online, and still cannot get the darn display to work.

I even purchased the SCC1 Sirius Receiver to connect to the DICE unit. Guess what? Of course it doesn't work. :rolleyes:

Since DICE is now owned by Audiovox, I was hoping for a better experience. Oh well. I checked online, verified the DUO firmware was up to date, and noticed that the Audiovox website does not have the K1200LT as being compatible with this unit. :wtf: Just about every other retailer out there that sells this thing has the K1200LT as a compatible vehicle. I purchased it from one of these retailers.

In doing more research, I found the Neo ProLink 2.0 POD2BMWV1, which claims to work with the '05 K1200LT on www.neocaraudio.com. Funny thing though, it looks EXACTLY like my DICE DUO unit, only with a NEO brand name on it. Could it be that Audiovox/DICE private labeled the product to NEO?

I have searched threads in here going back to 2006 and there are varying levels of success performing this upgrade. My question is, has anyone had RECENT success with any latest solution to get sound AND scrolling text coming through the stock '05 K1200LT setup? I am not interested in the Jenson setup....yet...LOL

If so, what is your secret? Pretty Please.....
:brick:
 

·
Registered
Joined
·
140 Posts
The DICE SilverLine Pro I-BMW-T on my '99 LT works like a champ and always has. iPod artist, playlists, song titles all displayed as advertised. I currently have my Garmin 660 connected through it for aural directions and MP3s too. MP3s don't show on the bike's display, but they are displayed on the Garmin unit.

Bill Edwards
Boerne, TX
 

·
Registered
Joined
·
93 Posts
Discussion Starter #8
stevea2980 said:
Now I am currious. I tried the CD / Dice replacement and it wouldnt work. They refunded my money and now I am reading two years later that there actually is a 99 LT out there that had a successful Dice install???

Please Explain.

Thanks

Steve A
Steve,

Back in 2006, I purchased a I-BMW-T DICE unit for my '99LT. This was a pre-silverline duo unit and it fully worked as advertised. I even had scrolling text on my radio display! I remember the DICE unit had two sets of DIP switches which needed to be set in a certain manner. It also did drain my battery a few times even if there was no iPod left plugged in.

This is what it looked like:





So, it sounds like something was configured wrong, or you may have had a defective unit or wiring harness.

DICE/Audiovox changed (updated the adapter) and now it seems that there are limitations with the interface with the K1200LT. With my new Silverline Duo DICE and my '05 LT, I have great sound, my handlebar controls work, but I have no display worth reading..

The Jenson marine radio or some other wired remote package is looking better and better to me. :D
 
1 - 8 of 8 Posts
Top