BMW Luxury Touring Community banner

1 - 12 of 12 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi Folks
On my way home from an extended trip around the Maritimes and Ontario, my 03 K1200LT stared to cut out. On the xway with cruise control on, it would drop to idle. The cruise light never went out. this happened several times but I made it home without the aid of a trailer. after I got home I ran a diagnostic on it with a GS911 and it said there is an idle switch short-to positive or open circuit. and idle regulator, signal implausible. Would that cause the engine to cut out? the bike has 198000 miles on it.
Thanks
Brian
 

·
Registered
Joined
·
1,223 Posts
Hi Folks
On my way home from an extended trip around the Maritimes and Ontario, my 03 K1200LT stared to cut out. On the xway with cruise control on, it would drop to idle. The cruise light never went out. this happened several times but I made it home without the aid of a trailer. after I got home I ran a diagnostic on it with a GS911 and it said there is an idle switch short-to positive or open circuit. and idle regulator, signal implausible. Would that cause the engine to cut out? the bike has 198000 miles on it.
Thanks
Brian
It would be way better if you save the "Auto-Scan" from GS911 onto a file (as offered in a menu item), so that I could see all data AND all error codes. To be able to post this file here, you may need to rename the extension to a ".TXT" as an ".Html" file might no be allowed as a file attachement here within a message.


Assuming you have only these 2 error-messages, then it is related to a defective (or nor correctly plugged) Idle-Actuator - this is also called TVA in some repair manual. In general, this will not cause the engine to cut-out at normal running RPM above idle. HOWEVER, it can cause engine to cut-out when throttle is close to downshift or to come to a stop (throttle forward at idle position).

If indeed the Idle-Actuator is defective, you would see that engine would not maintain proper idle speed in neutral either/Both when engine is hot or cold. It may become intermittent only when engine is very hot.

AND.... as always, the MOST IMPORTANT QUESTION: what recent work has been done on bike / engine if any?
It is possible someone did not fully pushed in the TVA connector on last maintenance and it became loose over time: this could generate these 2 error codes.

If it is not a typo in your message and engine has 198,000 miles with original Idle-Actuator (TVA), then it may just be a bit old and becoming intermittent. On our K1200 "brick-engine" this component has been very reliable in general BUT it contains a small stepper-motor with a plastic worm-drive mechanism that does wear out eventually. The more stop-go traffic, the harder the TVA is working.
 
  • Like
Reactions: saddleman

·
Registered
Joined
·
28 Posts
Discussion Starter #3
thanks for the info, I will attempt to send the gs911 report
 

Attachments

·
Registered
Joined
·
1,223 Posts
thanks for the info, I will attempt to send the gs911 report
Thanks for GS911 report. Both fault codes are related to info I posted earlier (idle actuator unplugged or defective).

HOWEVER there is one important added info from this report as both fault codes show: "The fault is not present now". This is important because it means these codes could have been there in memory for a long time: in particular, they will appear when someone attempts to set TPS using the GS911 (as the screens / prompts tells you to unplug TVA).

Hence, unless I know more about how / when the engine actually cuts out, we may be chasing the wrong path: the problem could be related to something else if indeed if does cut out at higher than idle RPM.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
The bike did indeed cut out at speed. cruising at freeway speed,bike would cut out but return to speed in a second or two. thought maybee fuel pump cut out or maybe a clogged filter. the thing purrs like a kitten otherwise. And it does have 198k on it...lol
 

·
Registered
Joined
·
1,223 Posts
The bike did indeed cut out at speed. cruising at freeway speed,bike would cut out but return to speed in a second or two. thought maybee fuel pump cut out or maybe a clogged filter. the thing purrs like a kitten otherwise. And it does have 198k on it...lol
These older Motronic EFI system do NOT have fault codes for incorrect fuel pressure OR when the fuel-pump is defective, hence you cannot rely on collecting fault codes for these anomalies. You need to go by probability, behavior, or accumulate more data / evidences. Of course we know that the K1200LT has problems when the fuel hoses inside the tank get old - this has been more common with usage of Ethanol and after these hoses are 5-to-10 years old (2 short hoses from / to fuel-filter inside tank)

If you do have a newer RED GS911, you have the ability to collect real-time data while you ride AND later download this data log for all sensors into a file. This may give us added clues as all sensors data is included including indirect data about Lean/Rich (based on O2 sensor data).
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
thanks, I'll hook it up and go for a ride
 

·
Registered
Joined
·
4,263 Posts
These older Motronic EFI system do NOT have fault codes for incorrect fuel pressure OR when the fuel-pump is defective, hence you cannot rely on collecting fault codes for these anomalies. You need to go by probability, behavior, or accumulate more data / evidences. Of course we know that the K1200LT has problems when the fuel hoses inside the tank get old - this has been more common with usage of Ethanol and after these hoses are 5-to-10 years old (2 short hoses from / to fuel-filter inside tank)

If you do have a newer RED GS911, you have the ability to collect real-time data while you ride AND later download this data log for all sensors into a file. This may give us added clues as all sensors data is included including indirect data about Lean/Rich (based on O2 sensor data).
John, would a side stand switch cause the cruise to drop out at speed? I have never actually tried to deploy the stand while in motion to test this as it would be hazardous.

Also, Brian, when this happens you say a second or two. Is it actually that long or is it more of a blip or a miss. A second or two would place you in an engine breaking deceleration situation and then back under power when it recovered.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #9
Went out for a ride with the gs 911 hooked up, of course it ran like a champ, figures. Think I will ake it to the dealer, maybe they have better diagnostic equipment.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #10
when it did happen, the engine did indeed decelerate to the point where I was heading to the shoulder to get out of the traffic flow. It would then come back on power and continue to operate normally until it happened again.
 

·
Registered
Joined
·
1,223 Posts
Went out for a ride with the gs 911 hooked up, of course it ran like a champ, figures. Think I will ake it to the dealer, maybe they have better diagnostic equipment.
If you visit a real BMW dealer, they have the BMW diag system and this will NOT give them more data or more fault codes than GS911. Some small non-franchise BMW dealer use a GS911 because they cannot get (or afford) the BMW diag system.

ONLY a quality and experience (many years) of a very good BMW mechanic will help you with such intermittent issue. All others (not enough experience), will only change parts/components until they find the offending one.

I have not seen your bike OR the GS911 real-time data, but the most probable based on your description would be either:
(1) bad ground or bad connection (any EFI related component)
(2) defective / worn ignition switch (more common on K1200 having 10 years or more with higher mileage)
(3) defective / intermittent fuel pump
 

·
Registered
Joined
·
28 Posts
Discussion Starter #12
Thanks for all the info. Im headed to the dealer today. I have not had a lot of experience with this dealer so I will hope for the best and keep you informed.... Thanks again
 
1 - 12 of 12 Posts
Top