BMW Luxury Touring Community banner

1 - 12 of 12 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
Cruise Control doesn't work :mad:

The little red light on the handle bar switch comes on but nothing on the instrument panel.

Tried to access the diagnostic routine but no luck there.

Any ideas? :confused:
 

·
Registered
Joined
·
313 Posts
On my trip from TN to Death Valley a couple of years ago, my cruise quit; which was not too great as I still had the old throttle cables on the bike. After getting to DV my right forearm looked like Popeye's from holding the throttle for that long.

I did get ahold of the diagnostic and ran it several times and every time is showed the throttle cutout switch at fault. After I got back home I replaced the throttle cables and adjusted the cutout switch. Still the diagnostic showed the throttle cutout switch at fault. After reading through this forum, I found that the clutch switch is usually the culprit. I cleaned and reset the clutch switch and viola' the cruise worked great; and has ever since.

Moral of the story, I'd check the clutch switch first, then the front brake switch and go from there. At least that's the path of least resistance.

HTH
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4

·
Registered
Joined
·
69 Posts
My cruise would drop out also or not set. Can't remember the lights but the clutch switch was the problem. When you pull in the clutch slowly without the bike running. you should hear 2 microswitches clicking. If not then one is out of whack
 

·
Registered
Joined
·
42 Posts
Discussion Starter #6
Two clicks audible on application of the clutch.

I have a new, well new to me, left handlebar switch arrangement on its way. Hopefully that may shed some light on the issue.
 

·
Premium Member
Joined
·
1,345 Posts
Is it just me or is that amber light on the cruise just too danged bright at night?........ :confused:
 

·
Registered
Joined
·
179 Posts
Pushing9:
How do ya get inside and clean the clutch switch? :bmw:
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
rattler50 said:
Is it just me or is that amber light on the cruise just too danged bright at night?........ :confused:
I'll let you know should I ever manage to get it to come on :(
 

·
Premium Member
Joined
·
1,305 Posts
rattler50 said:
Is it just me or is that amber light on the cruise just too danged bright at night?........ :confused:
Yep. Along with most of the other dash lights. My solution? Wally World windshield tint strip with 35% light transmission. I cut a rectangle to cover the offending lights. Sticks on with water. A 5 foot roll is about $5.

I also use a strip of this stuff at the top of my helmet face shield as a sun visor.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,249 Posts
If you can't get the unit to even start the diagnostic then I am afraid it is the unit itself that is toast. The red light will come on with the switch even if the cruise is unlugged as it is all external to the unit. May just check to make sure it is plugged in good.
 

·
Registered
Joined
·
1,334 Posts
jkersh1 said:
Yep. Along with most of the other dash lights. My solution? Wally World windshield tint strip with 35% light transmission. I cut a rectangle to cover the offending lights. Sticks on with water. A 5 foot roll is about $5.

I also use a strip of this stuff at the top of my helmet face shield as a sun visor.
Two tips for the price of one....thanky! :)
 
1 - 12 of 12 Posts
Top