BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter #1
Recently my K1200GT has started acting up on cruise control.

All works fine until I flick from dip to full beam, at which point if it's on cruise it goes off cruise.

Oddly if I hold it on headlamp flash it stays on cruise. If I go from full beam to dip it stays on cruise too.

I'm suspecting a possible earthing problem. Anyone ever experiened this problem?
 

·
Registered
Joined
·
186 Posts
Sounds like a low voltage problem. How old is your battery? I would also check the negative cable on the battery to see if it's snug.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #3
battery is the original from Sept 2007
 

·
Registered
Joined
·
203 Posts
Discussion Starter #4
UPDATE:

Further update:

http://www.youtube.com/watch?v=9uUzswLzzTw

Tracked it down to this .... and it turns out BMW extended warranty doesn't cover switchgear! Anyone confirm this as I'm REALLY disappointed that I went for the factory extended warranty and it doesnt cover the first thing to give problems.

The warranty booklet says the cover "Failure of the following parts: all electrical control units .... etc" which I read to mean switches as a switch is an electrical control unit but the dealers tell me no :S

The bike's a September 07 K1200GT with a mere 13000 miles on it.
 

·
Registered
Joined
·
203 Posts
Discussion Starter #5
I seem to have resolved the issue. I flushed it with WD40 and cleaned it out.

Which is just as well as apparently the switch is 277 UK pounds plus fitting!!!!

How is it that I can go and buy a really complicated electrical item such as a TV/Washing Machine/PC etc etc for less than a simple handlebar switch
 
1 - 5 of 5 Posts
Top