BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
303 Posts
Discussion Starter #1
I believe I have a relay issue with my cooling fans as the bike over heated and fan did not come on. Later I was on a very rough road and then the fans were working. Does anyone know if anyone makes a relay to fit besides BMW. 2000K1200lt. I kind of remember some issues with the relay but could find no previous posts on this issue.
 

·
Registered
Joined
·
303 Posts
Discussion Starter #3
I took it apart Today and Autozone can get the BMW relay. I had it crossed to a Borg Warner and they crossed it back and said it was a BMW part, go figure. First couple of places said was a special order and would take a few days. Autozone said they would have it next day. Will save me a drive to Louisville Ky. Needed to change the air filter anyway. Gambling on the relay as they started working on a very rough road. Thanks for the link.
 

·
Registered
Joined
·
303 Posts
Discussion Starter #4
Autozone relay was wrong. Drove to Louisville and bought 2 relays as horn has been hit or miss for couple of years. Installed new fan and starter relays and cooling fans and horn are now working properly.
 

·
Registered
Joined
·
315 Posts
So if I have one fan working and the other not it's not a relay but a wiring issue?
 

·
Registered
Joined
·
207 Posts
Thanks for the link MTREVELINO. Turned out to be a very easy fix. Cracked open the radiator cap. Burped the radiator hose a couple times and got some fluid to spit out. Took for an 80 mile stop and go and fast ride. Temp was perfect all around, and fan came on when needed. Air in the system was the culprit. How about that, an easy and cheap fix on a BMW LT lol.. Thank you.
 
1 - 6 of 6 Posts
Top