BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
Happy New Year!
Load up to ride today January 28,2007. Turn on radio light comes on but no radio,cd,cb/ no BMW on!!
Any ideas??? Check fuses all good.Where to now??
Randy
bimmer02
 

·
Registered
Joined
·
2,916 Posts
Have no clue, that sucks.
 

·
Registered
Joined
·
2,067 Posts
I know this sounds silly, but try doing the radio reboot. This amounts to disconnecting the battery for a period of about 30 minutes, then reconnecting it.

HTH, Ron
 

·
Registered
Joined
·
50 Posts
Discussion Starter #5
Com Failure

Question??? Does disconnecting the battery solve all of the LT's problems??ha ha
Rebooted my com with this advice. What else will this do for my LT???
rcbeemer
Thank you for the advice!!
 

·
BMW Guru
Joined
·
8,469 Posts
rcbeemer2002 said:
Question??? Does disconnecting the battery solve all of the LT's problems??ha ha
Rebooted my com with this advice. What else will this do for my LT???
rcbeemer
Thank you for the advice!!
If you disconnect the battery for a whole hour you can greatly decrease the possibility of a final drive bearing failure:histerica
 

·
Registered
Joined
·
92 Posts
Thanks Ron

kellenbenz said:
I know this sounds silly, but try doing the radio reboot. This amounts to disconnecting the battery for a period of about 30 minutes, then reconnecting it.

HTH, Ron
Gee -- after checking all fuses, after going a week with no comms, after taking off the stingray to check the fuse on the radio, I decided to read here. After leaving the battery disconnected during our N. GA ice storm, after going to home depot to buy a new nut for the battery post after dropping it somewhere down there (hmmm), hooked it back up and all works.

Now if I could only figure out how to turn off the alarm. Wife, kids, and neighbors weren't happy this morning! Did you know the alarm works when the battery isn't hooked up, but it gets louder with it! It will also turn itself off after waking everyone up...three times.

Now, after taking the stingray off, will some will surely tell me I did not have to? Next time I check here before!
 

·
Registered
Joined
·
874 Posts
dhendy said:
Gee -- after checking all fuses, after going a week with no comms, after taking off the stingray to check the fuse on the radio, I decided to read here. After leaving the battery disconnected during our N. GA ice storm, after going to home depot to buy a new nut for the battery post after dropping it somewhere down there (hmmm), hooked it back up and all works.
I was down to having the dealer install a new radio/VoiceII and they were in agreement! Then I rebooted it, now not only does the comm work but my tires are like new and I ride better. I reboot the battery every so often now just to see what else will get better!
 
1 - 8 of 8 Posts
Top