BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
351 Posts
Discussion Starter #1
went to my dealers yesterday (sat),after noticing the chrome strips on the fairing were loose on both sides , and guess what , by chance there was three other LT,s with the same problem. I pointed this out to the dealer and he was not aware of this problem as nobody had spotted this before .
These chrome strips look like they are glued on and are only fitted on the 04 and 05 updated models.
These chrome strips are a warranty item and my dealer is sorting this with BMW.

04 graphite. in good old Blighty
 

·
Registered
Joined
·
1,610 Posts
Same problem on this side of the pond

At first I tried to glue them together myself but then I asked the dealer to get new ones. Also the lowest trim (with K 1200 LT text on it) can fall off. Mine did when I was standing in a ferry line and engine idling (to feed power to my Gerbing suit). All of a sudden I heard a clink on the right side of my bike. The guy in a cage next to me was grining when I picked the piece up...
The fan gave so much heat to the trim that the glue behind the chrome gave up. I fixed it myself with some different type of adhesive. Now it seems to hold.

Regards
 

·
Registered
Joined
·
88 Posts
Me too!

Had one of those little guys pop off on my K12 as well. I used the all purpose adhesive Goop and a very thing black tie wrap to hold it in place while the Goop sat up. Been on ever since.

Who know this could be a warrenty item?
 

·
Registered
Joined
·
7 Posts
Bought a 6 month old LT last week, when I got it home and was giving it a good clean I noticed one of the chrome strips was held on with sticky tape, so reglued it and its stayed on so far
 
1 - 6 of 6 Posts
Top