BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
I have a 2003 k1200lt/se, it has done 47000 miles, i maintain it myself, to the BMW schedule, i regularly oil the centre stand, & have disassembled it on one occasion to grease it.
This afternoon i was in my garage, i was heaving it up onto the centre stand, it suddenly just fell away from me, landing on 3x pushbikes (pedal bikes), took me a couple of minutes to work out what had happened.
The tubular centre bar welded between the 2x centre stand legs had literally broken approximately 1" from the right side leg, no not at the weld, this caused the total failure of the stand, extremely luckily for me, it fell away & not onto me, as i would have been taken completely unaware & trapped under the bike at best.
I did not have any indications prior to this happening, i oil the centre stand approx every 4 weeks, when i removed the parts, there was plenty of lubrication at the bushes.
Is this a common fault, i have not heard of it on the LT before????, its a real danger when it happens, i now need a few parts, but thats the least worry, as no one hurt.
Yes i put my weight down on the centre stand arm & pull up on the handle, & it always works ok that way.
Any feedback as to wether this is common would be appreciated, also might be worth checking for you other owners, as you are snookered when it happens.
Regards
Stevie
PS, as it had fallen onto bikes, i had to use lifting gear from the rafters to get it upright.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
13,939 Posts
Not a common thing but there have been a few reported here. Most just pull it off and get it welded back. Some have added a stiffener.
 

·
Registered
Joined
·
2,176 Posts
Don't know if anyone else has watched this, but I've noticed, lately, how much movement or twising goes on when the bike settles in on the center stand. There has to be a considerable amount of stress placed on that stand until the bike stops moving. I've wondered if it has anything to do with how hard or quickly it comes up. Maybe I'm just pulling too hard, but it sure seems to move a lot.
 

·
Registered
Joined
·
3,137 Posts
Mine failed at almost the same spot a little over a year ago. I luckily had another Center Stand from a salvaged LT which I simply replaced it with. Still mean to see about welding the broken one back up, just have not done it yet.

John
 

·
Registered
Joined
·
372 Posts
Had a 96 R 1100 RT do the same thing. In my garage even. Lucky the wife was out driving her MGA when it happened or I would have had two to fix. Just took it off and welded it with some gussets to make sure it did not happen again
 
1 - 5 of 5 Posts
Top