BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
375 Posts
Discussion Starter #1
05 LT, 53,000 miles center stand won't pick up the bike. Was working fine until I used the center stand while pulling my trailer..... pushed the button and bike started to lift, then went back down. Now it won't lift the bike at all. Sounds like the motor is taxed when I push the button.

Anything I can check before pulling the center stand off the bike. ??

Thanks,

Chris Ogle
 

·
Registered
Joined
·
280 Posts
I just finished the center stand job myself. It was the motor; a $40 replacement.

You should plan to strip and clean the hydraulic components too.

When you put everything back together, make sure you properly flush the air out. I did not and though it worked well on the bench, under load it won't pick up to the fulcrum point. I now have to re-do my work.

The job is not nearly as scarey as it sounds.
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,346 Posts
Motor is one cause but this can also be a result of loss of fluid. I just rebuilt one and all had to do was take it apart and clean all the seals. There were two stripped fill port screws that I replaced with slightly longer M5 0.8 bolts. I added 130ml (never add more than 150ml) of oil and she was back in shape. I will be offering rebuild service as soon as all the seals I ordered come in. But there are excellent instructions posed in the "Files" "technical" area. You can remove the actuator with out removing the centerstand. Just loosen the the bolt on the exhaust banjo and remove the two skid plate bolts (8mm hex) followed by the two 5mm hex side bolts. It will drop down enough to pull the actuator.
 

·
Premium Member
Joined
·
375 Posts
Discussion Starter #4
Thanks guys, I will pull the center stand today.
John: I found a pdf file with good info in the tech section.

Thanks,

Chris Ogle
 
1 - 4 of 4 Posts
Top