BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
ive tried searching, but i just cant find my specifics. If anyone can point me to a previous post that shares my situation, please show me so that i dont waste anyones time with multiple threads covering the same topic.

I have a 2000 LT with an Autocom and i really want to install a CB before our next long trip over the 4th of July. Is there a simple installation? ive heard that you can hook a handheld CB up to the Autocom, but you can only use certain models and some installations are harder than others as you have to open the CB itself and solder wires in place. Ive also been told that i cant put the factory BMW cb on my bike because it doesnt have the proper wiring from the factory.

I guess my question is, what is the simplest, easiest solution to a CB for the LT? also, if you use the handheld CB option, how do you key the mic to talk?? or does it just key anytime you talk? (that would get kind of annoying as i am quite the "road singer" on long trips :D )
 

·
Registered
Joined
·
35 Posts
Hello Terry,
I also have a 2000LT and have been trying to come up with the best cb solution.
I have the Autocom proM1 installed on the bike. I use a hand held cb (Cobra 38 wxst), as suggested by autocom. This required a PTT switch and a cable to get it into the autocom system. The unit is not powered from the bike at the suggestion from autocom I think to avoid interference from the bike.
The system seems to work ok but the range is limited. A few cables and installing a PTT switch on the handle bar got me on the air rather quickly.
I see no reason why a frs or gmrs handheld unit would not work here with the right cord from autocom.
I have a strap that goes around the oddments box cover that I clip the radio to when I want to use it.
Good luck

Denny
 

·
Registered
The Villages, FL
Joined
·
2,601 Posts
I had the Midland cb on my 2000LT and switched to the Cobra. The Midland produced a loud noise while transmitting. At first the Cobra worked great, but then started producing the noise. I have been delaying this but I hope to mount the cb with a ram mount and use the cb's stock antenna. The cb is currently sitting in the left saddle bag. I can turn it on, set the channel, and that is about it. I am sure that the antenna is what is causing the loud noise while trying to transmit. ALso, I have the Autocom and have installed the bmw ptt switch. I just spliced the bmw switch into the autocom wiring harness. This has worked great.
 
1 - 3 of 3 Posts
Top