BMW Luxury Touring Community banner
1 - 4 of 4 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
I recently purchased the newest Cardo G9 Powerset. I paired up one of the G9 units to my GTL BT. The pairing was quick, the problem is the audio. Spoken word (AM, Sirius talk radio), is ok, as is the GPS voice. But the 2-channel audio is horrible. FM or Satellite are pretty bad, but the iPod is way worse. It crackles and distorts no matter what the tone or volume settings are. It sounds as if the BT transceiver and receiver are 2 blocks apart. But they're only 2-3 feet.

My use for the system is about 80% for music. I doubt the problem is the speakers, they seem adequate. I haven't set up the second unit in my wife's helmet. But if the music is this bad, I won't bother with the second installation.

It looks like I may return this unit and dig deeper in my pockets and buy the BMW BT set up. It looks like BMW played this one perfectly; purchase OUR system at a high price, or suffer the consequences of purchasing another brand...
 

·
Registered
Joined
·
2,104 Posts
reset verything back to factory, and do it again. If it does not work then return it. I had to do that with mine and it works fine.
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #3 ·
sheldan2 said:
reset verything back to factory, and do it again. If it does not work then return it. I had to do that with mine and it works fine.
By 'fine', do you mean that the audio portion is clear and distortion free when listening to the Sat or iPod? Other posts I've read on this site and the K1600 site is that no matter what system you try, it will always have problems and unclear audio because of BMW's propritary firmware on the GT(s).
 

·
Old Slow Guy in A Fast Car
Joined
·
8,603 Posts
starvingdrummer said:
By 'fine', do you mean that the audio portion is clear and distortion free when listening to the Sat or iPod? Other posts I've read on this site and the K1600 site is that no matter what system you try, it will always have problems and unclear audio because of BMW's propritary firmware on the GT(s).
You just answered your own question. I have a G4 with the newest software updates & it still will not work right with the K1600. I do like the Scala G4 so I hard wired my bike with a 3.5 mm Female audio plug & just plug the G4 into the bike. I use Bluetooth to talk to my Passenger & a riding buddy plus I paired my phone to the G4

CLICK HERE to see how I did it.
I have less then $100.00 in this (not counting the 2 G4's I already had) & it works flawlessly.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top