BMW Luxury Touring Community banner

Cardo Scala G4

4382 Views 21 Replies 5 Participants Last post by  Knife
I have decided to purchase the Scala G4. I have seen several listed on Ebay and the prices range from just over 300 to over 400. It seems that they are all the same but I'm not quite sure. Any ideas???
1 - 9 of 22 Posts
katnapinn said:
David, That looks about right for the powerset. I think I paid about $350.00 shipped last year for mine. They are great & I love how long the battery last. I have gone 15 to 16 hours with mine plugged into my bikes audio on one charge. Just recharge it over night & go again the next day. Using the audio in port keeps one channel open all the time & I have to tap the comm button (turns audio off & comm on) to talk to my wife or another rider with a G4. Well worth every penny. :thumb:

Thanks for the reply, I will simply order the least expensive one.

I have an 09 LT, I'm not sure if I have an audio plug like you are talking about. Was this an option?

I am concerned about my helmet, I have a shark evoline that is very tight. It doesn't seem to have a place for an earpiece.
sheldan2 said: has the g4 for $339. Free shipping. Saw them there yesterday. I have bought 2 sets from them so far. One for myself and one set for a family member.

I already ordered one from ebay but this looks like a great site. I saved it in my favorites! Thanks.
I received the G4. It seems to work pretty well but I'm having a slight problem maybe you can help me with. If I am listening to music on my droid x2 and my wife talks on the intercom it cuts off the music which I expected but when we are done using the intercom the blue tooth does not connect back with the G4. the music just comes out of the phone speaker. The phone still indicates that it is connected with the G4 but no music in the helmet.

Any ideas??
sheldan2 said:
I had the same issue, was told to press the middle button to get the channel back. Tried that a few times. I did do the latest update and it seems to have fixed the issue. I did change the settings on the vox as well, this is done while the unit is plugged into the computer.

When I press the middles button it activates the voice commands on the phone.

I attempted to update it, not sure if I got that right.

What did you change the vox settings to?
This is a bummer, the unit is updated. It still won't reconnect with the phone. I have to shut it off then turn it back on to get it to reconnect after we use the intercom. That will stink going down the road. On top of that the music is paused on the phone so I'll have to push the play button on the phone to get the music to play again.
sheldan2 said:
David, call scala directly, they will help, I have called them numerous times when I had questions.

I've sent them an email. Will call them monday!
Knife said:
Did you try tapping the A (MP3) button?

I just tried it. It did not work. I thought that the A button manually activated the intercom. Not sure yet how that button controls the MP3 and the intercom.
I finally talked to Cardo, it seems that my phone, the Droid X2 has issues with reconnecting after using the intercom. This is a problem they are familiar with and they are working on. As of now I have to power down the G4 then power back up to reconnect with my phone and continue listening to music. I am not happy about this but what can I do??
1 - 9 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.