BMW Luxury Touring Community banner

1 - 20 of 22 Posts

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #1
I have decided to purchase the Scala G4. I have seen several listed on Ebay and the prices range from just over 300 to over 400. It seems that they are all the same but I'm not quite sure. Any ideas???
 

·
Old Slow Guy in A Fast Car
Joined
·
8,602 Posts
David, That looks about right for the powerset. I think I paid about $350.00 shipped last year for mine. They are great & I love how long the battery last. I have gone 15 to 16 hours with mine plugged into my bikes audio on one charge. Just recharge it over night & go again the next day. Using the audio in port keeps one channel open all the time & I have to tap the comm button (turns audio off & comm on) to talk to my wife or another rider with a G4. Well worth every penny. :thumb:
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #3
katnapinn said:
David, That looks about right for the powerset. I think I paid about $350.00 shipped last year for mine. They are great & I love how long the battery last. I have gone 15 to 16 hours with mine plugged into my bikes audio on one charge. Just recharge it over night & go again the next day. Using the audio in port keeps one channel open all the time & I have to tap the comm button (turns audio off & comm on) to talk to my wife or another rider with a G4. Well worth every penny. :thumb:

Thanks for the reply, I will simply order the least expensive one.

I have an 09 LT, I'm not sure if I have an audio plug like you are talking about. Was this an option?

I am concerned about my helmet, I have a shark evoline that is very tight. It doesn't seem to have a place for an earpiece.
 

·
Old Slow Guy in A Fast Car
Joined
·
8,602 Posts
dthogey said:
Thanks for the reply, I will simply order the least expensive one.

I have an 09 LT, I'm not sure if I have an audio plug like you are talking about. Was this an option?

I am concerned about my helmet, I have a shark evoline that is very tight. It doesn't seem to have a place for an earpiece.
The Scala has an Audio in port & comes with a coiled 3.5mm double male cable. I have my GTL hard wired into the speaker wires with a 3.5 mm Female jack & just plug into the bike for audio & GPS. I also removed the speakers from the Scala & wired in a Female 3.5 mm jack into the speaker wires so I can plug in Ear Buds. This way I do not have to mess with speakers & ear plugs.
 

·
Registered
Joined
·
2,104 Posts
Www.compacc.com has the g4 for $339. Free shipping. Saw them there yesterday. I have bought 2 sets from them so far. One for myself and one set for a family member.
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #6
sheldan2 said:
Www.compacc.com has the g4 for $339. Free shipping. Saw them there yesterday. I have bought 2 sets from them so far. One for myself and one set for a family member.

I already ordered one from ebay but this looks like a great site. I saved it in my favorites! Thanks.
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #7
I received the G4. It seems to work pretty well but I'm having a slight problem maybe you can help me with. If I am listening to music on my droid x2 and my wife talks on the intercom it cuts off the music which I expected but when we are done using the intercom the blue tooth does not connect back with the G4. the music just comes out of the phone speaker. The phone still indicates that it is connected with the G4 but no music in the helmet.

Any ideas??
 

·
Registered
Joined
·
2,104 Posts
I had the same issue, was told to press the middle button to get the channel back. Tried that a few times. I did do the latest update and it seems to have fixed the issue. I did change the settings on the vox as well, this is done while the unit is plugged into the computer.
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #9
sheldan2 said:
I had the same issue, was told to press the middle button to get the channel back. Tried that a few times. I did do the latest update and it seems to have fixed the issue. I did change the settings on the vox as well, this is done while the unit is plugged into the computer.


When I press the middles button it activates the voice commands on the phone.

I attempted to update it, not sure if I got that right.

What did you change the vox settings to?
 

·
Registered
Joined
·
2,104 Posts
vox and agc settings are on low. Double check when you connect the scala to the computer and turn it on, go to updates, and it should tell you whether the update took. It has taken me a few tries to get it updated.

I did use the unit with an iphone recently and it worked without a hitch, music, talk etc. I just don't like i-anything. But it is working fine with my bionic.
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #11
This is a bummer, the unit is updated. It still won't reconnect with the phone. I have to shut it off then turn it back on to get it to reconnect after we use the intercom. That will stink going down the road. On top of that the music is paused on the phone so I'll have to push the play button on the phone to get the music to play again.
 

·
Registered
Joined
·
2,104 Posts
David, call scala directly, they will help, I have called them numerous times when I had questions.
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #13
sheldan2 said:
David, call scala directly, they will help, I have called them numerous times when I had questions.

I've sent them an email. Will call them monday!
 

·
Registered
Joined
·
290 Posts
Did you try tapping the A (MP3) button?
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #15
Knife said:
Did you try tapping the A (MP3) button?


I just tried it. It did not work. I thought that the A button manually activated the intercom. Not sure yet how that button controls the MP3 and the intercom.
 

·
Old Slow Guy in A Fast Car
Joined
·
8,602 Posts
dthogey said:
I just tried it. It did not work. I thought that the A button manually activated the intercom. Not sure yet how that button controls the MP3 and the intercom.
it controls both You tap it the first time it connects the comm. Tap it again it turns off com & resumes music. At least that is how it works on mine.
 

·
Registered
Joined
·
2,104 Posts
Do you have it paired to a GPS?
 

·
Registered
Joined
·
2,104 Posts
If you have 2 units, make sure they are paired correctly, unpair them and pair up again. Do the same with your phones. One phone for each unit.Get your vox and AGC levels down to low. (Section 4.2) go outside, talk to each other, get that channel going. Then call your phone, you can either voice answer or press the middle top button, this should open that channel. I prefer to press the button. Hang up, turn on your music. Then talk again. It might take a few seconds for it to switch over again to intercom mode. Stop talking, you will hear a faint click as it closes the intercom channel, and it should now start playing music again. I am still learning the system myself, but this was the way I got it to work for me. I hope it helps.
 

·
Registered
Joined
·
2,104 Posts
Got it paired to another bike rider yesterday, worked as advertised, out to around a mile, got it functioning between both riders, passenger, and 3 cell phones with music. We did have to power down and back on again a couple times, but it came back fully functional. Overall happy with the units, it just takes a bit to get it all functional .
 

·
Premium Member
Joined
·
1,157 Posts
Discussion Starter #20
I finally talked to Cardo, it seems that my phone, the Droid X2 has issues with reconnecting after using the intercom. This is a problem they are familiar with and they are working on. As of now I have to power down the G4 then power back up to reconnect with my phone and continue listening to music. I am not happy about this but what can I do??
 
1 - 20 of 22 Posts
Top