BMW Luxury Touring Community banner

1 - 8 of 8 Posts

·
Registered
Joined
·
161 Posts
Discussion Starter #1
I love the cd player on my bike and it decided to quit working.It says no disc on the display.It is the 6 disc player.It loads the magazine ok and I even bought a new one but no luck.
Any ideas?
Thanks in advance
 

·
Registered
Joined
·
866 Posts
Sounds like an electrical problem to me..... do you have an LT manual to trouble shoot ?
 

·
Registered
Joined
·
300 Posts
sorry if this sounds way to simple... no offense intended... when i first started with the CD player it always read no disc when hitting the CD button. on the second hit of the button she fires right up. it still works that way for me... to pushes of the CD button. i hope it's that simple for you. i too love the cdplayer.
 

·
Registered
Joined
·
18 Posts
Mine does this also and I think it is first searching the single disk player up top and when pushing the cd button a second time you are directing it to look at the changer for disks.
 

·
Registered
Joined
·
336 Posts
That is correct. Turning on the CD plays the one in the stingray. Second push selects the six-disc changer.
 

·
Premium Member
Joined
·
1,305 Posts
There is a 3 amp fuse on the back of the changer near the interface connectors. Might be worth checking if it has blown.
 

·
Super Moderator
Joined
·
1,401 Posts
Little CD Trouble Shooting for Those with Issues

The BMW CD Changers have three receptacles in the back of the units one is for power and the another for audio. There is also a DSP (Dynamic or Digital Signal Processing) connection - I do not believe any bikes use this and it is mostly for specific cars with high ends radio set ups - see picture attached.

Now on to more importantly the other outlets. One of these receptacles hosts a connection I believe is called the iBus connection...

What is iBus - simple explanation:

BMW's I-Bus is in the car for handling interfacing between the radio, CD, navigation, and telephone systems. In particular, the steering wheel controls for the radio, CD, and phone utilize the I-Bus.

In cars the I-Bus is a single wire bus that is a white/red/yellow wire which is available at a number of different connectors inside the car such as at the CD changer connector in the rear, the phone connector in the center console, etc.

The reason you should know this is the LT has controls just like a car:

1. On the radio
2. On the handlebar (just like a steering wheel)

It is iBus that sends and receives signals and it resides on current carrying conductors. So with out dragging you into a very technical discussion of which I am totally unqualified to have here are a few things you may wish to check to resolve transient control issues:

Take apart all plugs associated with the radio and put dielectric grease on them - this applies to under the tupperwear, on the handle bar and on the back of the CD in the side compartment.

The transient problems you have can be in fact be corrosion issues. We are prone to more of them than in a car - go figure!!

Also weak batteries or a poor charging system can also be a culprit since corrosion at terminals can effect voltages . . .

BTW, iBus connections, communications and issues have been at the forefront regarding iPod integration with BMW.

If any sparkies out there want to get into the details, knock yourself out at:

http://www.openbmw.org/bus/
http://autos.groups.yahoo.com/group/HackTheIBus/

Good luck!!
 

Attachments

1 - 8 of 8 Posts
Top