BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
602 Posts
Discussion Starter #1
For the last several weeks I have been getting the wig-wag ABS lights. The battery is fully charged so I pulled the tuperware so I could get a good look at the brake fluid level. I think I found the problem. The reservoir is broke where the front sensor plugs into it. I called the local BMW shop and ordered another reservoir. The shop manager said that he had never seen a reservoir break like that. Just curious, has anyone seen this problem? :confused:

Al
 

·
Registered
Joined
·
2,651 Posts
Never heard of it before but I have only been around here for a couple of years.
 

·
Premium Member
Joined
·
565 Posts
Do you mean the front brake master cylinder resevoir? If so, yes, I had a leaky one on my 97 RT. The cylinder was replaced under warranty as was the right side body panel. Brake fluid had leaked onto the plastic and damaged the paint. Happened on a trip to NJ. I got mildly screwed by Youngstown BMW, Cherry Hill BMW took care of the cylinder, and Grand Rapids BMW replaced the body panel once I returned home. No big deal.
 

·
Registered
Joined
·
602 Posts
Discussion Starter #4
Matt said:
Do you mean the front brake master cylinder resevoir? If so, yes, I had a leaky one on my 97 RT. The cylinder was replaced under warranty as was the right side body panel. Brake fluid had leaked onto the plastic and damaged the paint. Happened on a trip to NJ. I got mildly screwed by Youngstown BMW, Cherry Hill BMW took care of the cylinder, and Grand Rapids BMW replaced the body panel once I returned home. No big deal.
Yes that's the one. I was planning on have all the fluids changed out in March, so I guess I will just take it in a few weeks sooner.
 
1 - 4 of 4 Posts
Top