BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter · #1 ·
I was adding an LED brake light kit to my 2000 LT. I ran the wire off the harness behind the rear lens up under the top case and out to the light strip. Anyway, to make a long story short, I pinched the wires while installing the top case and shorted out the brake lights. I assumed it would have blown a fuse but upon checking, I noticed that the fuse was a 15 amp while the manual calls for a 4 amp. ( I suppose the PO did this??)
The fuse did not blow and I do not have any brake lights. I checked the bulbs and they are all good, so do you guys think I blew the brake light relay? I did some research in the archives and from what I can tell, I need to take off the right side tupperware, and the relay is somewhere under the gas tank? Is this correct? By the way, I am supposed to leave in the morning for a trip through the Ozark mountains with another couple, I don't think that will be happening....
 

·
Registered
Joined
·
74 Posts
Discussion Starter · #2 ·
TVPearson said:
I was adding an LED brake light kit to my 2000 LT. I ran the wire off the harness behind the rear lens up under the top case and out to the light strip. Anyway, to make a long story short, I pinched the wires while installing the top case and shorted out the brake lights. I assumed it would have blown a fuse but upon checking, I noticed that the fuse was a 15 amp while the manual calls for a 4 amp. ( I suppose the PO did this??)
The fuse did not blow and I do not have any brake lights. I checked the bulbs and they are all good, so do you guys think I blew the brake light relay? I did some research in the archives and from what I can tell, I need to take off the right side tupperware, and the relay is somewhere under the gas tank? Is this correct? By the way, I am supposed to leave in the morning for a trip through the Ozark mountains with another couple, I don't think that will be happening....
Wow, after posting my question, I just kept reading on the forum. I found one particular post about the same problem and someone replied to check the top fuse AND the third fuse down, low and behold, the third fuse was blown!!! Now, why doesn't the manual tell us that??
A BIG thanks to all those who contribute on this site. If I hurry up, I can get the bike back together and still make my trip in the morning.
Once again, thanks!!
 

·
Registered
Joined
·
3,232 Posts
Have a great trip, Terry!
cheers
 
1 - 3 of 3 Posts
Top