BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1 (Edited)
Both of my Brake Failure red lights flash while riding and I've checked the reservoir and it's full. I still have full ABS have braking action. Additionally, both of my outside brake lights do not work, but the flasher portion of the bulbs work. Checked the fuses and they are ok.
Any ideas where to go next?:bmw:
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,254 Posts
You say you checked the reservoir, but these are notorious for being very sensitive to fluid level. Try adding a teaspoon of fluid to both the front and rear halves of the reservoir.
 

Attachments

·
Enjoy The Ride
Joined
·
3,989 Posts
You say you checked the reservoir, but these are notorious for being very sensitive to fluid level. Try adding a teaspoon of fluid to both the front and rear halves of the reservoir.
+1 on what John said fill them until when you install the caps they run over just a little.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #5
Thank you both for your replies and I didn't know there was a rear chamber. I'll check that:bmw:
 

·
Registered
Joined
·
179 Posts
Discussion Starter #6
Dave:
Thank you for your input and I did find a rear brake line leaking just a little bit and the forward chamber very low (After taking off the rear footpeg and Tupperware). Now the lights go away. I now have to replace the brake line.
GREAT forum!!:wave:bmw::dance:
 
1 - 6 of 6 Posts
Top