BMW Luxury Touring Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I just bought my K1200LT a few months ago. When I got it, it ran great, with just some erratic idle.problem. The bike was from an estate sale then the new owner decided to quit riding after they were able to adopt a child.and sold both his bikes. So, he told me about the erratic idle and that he had put some Fuel Injector cleaner in the fuel. The idle problem then started causing the bike to die at times when going to idle. And even while running at speed it would stumble at times. I decided to put in iridium plugs and upgraded fuel injectors. I'm putting them in this weekend. I have a Clymer manual, but I'm wondering if anyone has seen this problem before and has any advice.
 

·
Premium Member
Joined
·
2,086 Posts
First, welcome to the asylum. Plenty of help available.

Check spark plug wires. Remove cover and run at night looking for crossfire between
wires. Then lightly water mist and do the same.

Bring to my place in Fulshear and we can check it out.
 

·
Registered
Joined
·
12,165 Posts
Erratic idle is also pretty commonly caused by a vacuum leak. Pull the left side Tupperware and check the four vacuum lines to the throttle bodies. If one is off, idle will be anyware from stall to 2,000 RPM.

If none of these work, you could have a very rare (actually never heard of one) throttle positioner failure.
 

·
Registered
Joined
·
676 Posts
When you pull the fairings, don't forget to look for rodent damage if the bike sat for a long time while the estate was being settled.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Well, thanks for the advice. I've been an auto mechanic for a long time and I've worked on bikes but nothing major. So, I know the basics to look for, but this just seems baffling. Anyway, I have have seen trouble similar to this before and it was due to using too high octane gasoline. So, I dropped from 93 to 89 octane and put a whole bottle of Fuel System Cleaner (Techron) and it got worse, a lot worse. But then today after running it some more it cleared up and began running just fine. So, the question now is, what octane do you guys run?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
13,922 Posts
Best to run premium as there is no knock sensor to retard timing on the LT. I have seen two bikes that have had piston ring land fractures from detonation. Not too hard to fix unless the ring breaks and scores the cylinder wall, then it is change engine time.
 
1 - 7 of 7 Posts
Top