BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi guys,

I can't believe at my ability to mess things up...

Here's what happened...

Virgin effort... Removed the side fairings and radio stingray for the first time on a '00 so that i can get to the 8 button remote.. There was some corrosion on the board so I could turn on the radio.

I thought everything was alright and even rode it for a while before parking it back when all the plastics were back on.

This morning as I was going to work, I warmed up the bike as usual. Everything seemed normal for the first 3 minutes, idling at 1000rpm. The next 2 minutes, idling dropped from 1000rpm to 800, then to 600 and finally died. Needed to blip the throttle to start it but will die off immediately.

I rode it to work anyhow, but was mindful that I needed to pull a little on the gas all the time so that the engine will die off.

Read that the vacuum hose could be a suspect. Not too sure if there is anything else to look for.

Would you guys here have any ideas?

Lots of thanks
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Will pay attention to it - Thanks

I thought I didn't plug in a connector correctly. I'll pull off the right panel first then.

Lots of thanks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
8 laters still no luck

Hi guys,

It's now coming to 4 am Singapore time. I started at 8pm. Thought the right should be sufficient but ended up tearing out the fuel tank too just to take a good look at everything.

Seems fine to me. I traced the vacuum from the top of the tank to rear of the bike, blew into it and was sure air could go out on the other end.

The cables on the right fairing on the bike looks fine. I saw the plastic shieldings around alot of wires coming off because of old age but no wires was exposed (to my blind eye).

Do you guys think anything else is not right?

The bike is able to idle for about 3 minutes at 1000rpm, then rpm decreases over about another 3 minutes when the bike is getting warmed up stationary, and eventually dies off.

While riding, i can't take my hands off the throttle even while changing gear. RPM will go down and bike will die off.

Thanks in advance.
 

·
Registered
Joined
·
494 Posts
I second the check vacuum hoses. The same thing happened to me when my dealer pinched the right side hose when they serviced the bike. Runs like a dream now.
Jim
 
1 - 5 of 5 Posts
Top