BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
After a recent power flicker at my house, I noticed my Battery Tender Plus seems to be acting odd. Normally when I would connect it (through the lower left powerlet) I'd get the solid red light immediately, followed by the flashing green, then after a few hours the solid green with no red. Which is the normal sequence. But now since the power flicker, when I hook it up I get no lights at first, then the green starts to flash (with no red) and seems to stay flashing forever without ever going solid. The no red/flashing green configuration does not match anything in the owners manual or trouble shooting sections from Deltran. Even Google doesn't seem to bring up anyone else who has encountered this. Should I be concerned?

And this may be coincidental but, since this started happening, I've also noticed some alternator noise through the radio at higher RPMs. Both the battery and the Tender were purchased October 2011.
 

·
Registered
Joined
·
338 Posts
You may have had a power surge that damaged certain items. It happened to me during an electric company employee screw up who sent 220V momenterly into my house, some things got fried, some lightbulbs exploded, yet the television remained untouched.
One transformer was actually melted.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #3
lesn said:
You may have had a power surge that damaged certain items. It happened to me during an electric company employee screw up who sent 220V momenterly into my house, some things got fried, some lightbulbs exploded, yet the television remained untouched.
One transformer was actually melted.
That is one possibility. The flicker happened while I was asleep. It must have been very brief, because only two of my four digital clocks were flashing when I woke up, and my desktop PC that I keep on standby mode did not shut down. Nothing else is damaged.
 

·
Registered
Joined
·
1,137 Posts
I've had something similar happen to two Battery Tenders in the last few years. One of them, I know, was due to a lighting strike.

Each time I called their 1-800 number and they replaced the unit.

I had to mail them the defective unit with a check for $10 to cover shipping. At least I think it was $10. A couple of days later, I received a completely new replacement unit.

One call, that's all.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #5
wardenross said:
I've had something similar happen to two Battery Tenders in the last few years. One of them, I know, was due to a lighting strike.

Each time I called their 1-800 number and they replaced the unit.

I had to mail them the defective unit with a check for $10 to cover shipping. At least I think it was $10. A couple of days later, I received a completely new replacement unit.

One call, that's all.
That's encouraging news at least. I sent them an e-mail last night, so I'll give it some time to see if they respond.

After leaving the BT+ on overnight from 4pm to 7am I still had the flashing green light with no red light, so I'm going to discontinue using it on the LT until I hear from Deltran. I may try hooking it up to my tractor battery over the weekend to see if it behaves differently on that one.
 
1 - 5 of 5 Posts
Top