BMW Luxury Touring Community banner

1 - 11 of 11 Posts

·
Registered
Joined
·
368 Posts
Discussion Starter #1
I recently replaced the OEM exhaust on my 2003 LT with 60K with a Remus Street Can due to the fact that the OEM had a hole that had rusted thru. I also inserted the pipe in the end to cut down on the drone. When I ride the twisties I always stay in low gear with high RPMs to take advantage of engine braking. Now I get a lot of popping and an occasional backfire when doing that. I changed to premium grade fuel and was considering a RhineWest chip thinking that would solve my problems. After doing a bit of searching on the forum it appears that the RhineWest chip won't really cure my issue. I don't mind spending the money if it will cure my issue but don't want to spend the money if I still have the issue. Any other ideas?
 

·
Registered
Joined
·
656 Posts
KayGee said:
I recently replaced the OEM exhaust on my 2003 LT with 60K with a Remus Street Can due to the fact that the OEM had a hole that had rusted thru. I also inserted the pipe in the end to cut down on the drone. When I ride the twisties I always stay in low gear with high RPMs to take advantage of engine braking. Now I get a lot of popping and an occasional backfire when doing that. I changed to premium grade fuel and was considering a RhineWest chip thinking that would solve my problems. After doing a bit of searching on the forum it appears that the RhineWest chip won't really cure my issue. I don't mind spending the money if it will cure my issue but don't want to spend the money if I still have the issue. Any other ideas?
Just a thought Keith but it sounds like your mixture has gone lean when was the last time the O2 sensor was changed?
 

·
Registered
Joined
·
368 Posts
Discussion Starter #3 (Edited)
Kra961 said:
Just a thought Keith but it sounds like your mixture has gone lean when was the last time the O2 sensor was changed?



Are you refering to part #1?

Lambda Monitor sensor L=580MM 1 11781742051 $261.07
 

·
Registered
Joined
·
339 Posts
I don't know, I've got a 2000 with a remus and it backfires. Before and after a new o2 sensor...
 

·
Premium Member
Joined
·
1,428 Posts
lartross said:
I don't know, I've got a 2000 with a remus and it backfires. Before and after a new o2 sensor...
+1... Well, she used to anyway... *sniff*sniff* :crybaby:
 

·
Registered
Joined
·
1,106 Posts
My 99 with Remus and the chip does the same thing. Agree that it could be the O2 sensor.
 

·
Registered
Joined
·
3,089 Posts
My '03 does that too with the Remus pipe.

You have an exhaust leak somewhere, probably where the muffler slips on the intermediate pipe.
 

·
Premium Member
Joined
·
1,561 Posts
My '03, with remus complete exhaust system, sometimes backfires, sometimes not.
On its third o2 sensor with no change.............
 

·
Premium Member
Joined
·
2,024 Posts
I have both the chip & exhaust on my '01 and it's a matter of how rapid the decel is, air temp etc. some times I get backfire, mostly not although I'm more gentle on the throttle let off except for urgent situations.
 

·
Registered
Joined
·
1,009 Posts
O2 sensor will cause it to run richer when it fails, gas mileage will really go bad, I know on the K100's when the throttle was fully closed the fuel injection was shut off until RPMs went below 1500, may be different with motronic, a more open exhaust on anything will usually result in snapping and cracking, less back pressure
 

·
Registered
Joined
·
552 Posts
I have a 2000 with exhaust and chip and get some backfires as well. Much like BennyBob. Depends on the day, but I notice it normally happens when I downshift into a turn and hit high rpms with a big release of the throttle at the same time.
 
1 - 11 of 11 Posts
Top