BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I just purchased a used K1200LTC with about 65,000 miles on it. The seller reports that he had a problem with fuel backfiring in the cat conv while the engine is cold. I am finding that it "backfires" or rattles, or SOMETHING not only when it is cold, but all the time...not only when I let off the gas, but while accelerating, particularly between 3000 and 4000 RPM. Anybody have a similar experience...and hopefully, solution???????
 

·
Registered
Joined
·
1,836 Posts
PilotPhil said:
I just purchased a used K1200LTC with about 65,000 miles on it. The seller reports that he had a problem with fuel backfiring in the cat conv while the engine is cold. I am finding that it "backfires" or rattles, or SOMETHING not only when it is cold, but all the time...not only when I let off the gas, but while accelerating, particularly between 3000 and 4000 RPM. Anybody have a similar experience...and hopefully, solution???????
Phil sounds like the cat conv broke free inside the collector. I had the same experience. You may note eratic idyl . A cheap fix is to remove exhaust and open up the collector from the top and remove the cat then reweld (stainless). I am not sure how the bike will run after removing the cat.You may lose some low to midrange power.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Thanks, Pete. I have a neighbor who has the ability to weld stainless. That sounds like a good starting point. It doesn't seem to affect performance, but is very annoying, especially when on such a smooth running machine.
 
1 - 3 of 3 Posts
Top