BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
719 Posts
Discussion Starter #1
I noticed this week the bike was making as much noise as a freight train when rolling. At first I thought it was the worn out front tire. Last night I changed the front tire and found the rear drive all loose and rough. Typical bearing failure. :crybaby:

I had been changing the FD fluid more often than the engine oil (every 2-3k) since I got the bike two years ago. There has been small particles in the oil and on the magnet. So this failure does not come as a surprise. But it is still unwanted. :(

Question: is the LT final drive the only one that fits? I've seen some k12GT and RS drives on ebay and although the p/n is not the same, they have the same gear ratio and speedo hole.
edit: never mind, I see the mounting bosses are not the same for the GT and RS.

thanks and ride on. :bmw:
 

·
Premium Member
Joined
·
2,086 Posts
Dave, do you want me to bring you a loaner tomorrow to the RTE? Yours to use until you get yours rebuilt.

Dan Martin
 

·
Registered
Joined
·
719 Posts
Discussion Starter #3
Dan,
thanks for the offer. I'm not sure I'll make it to the RTE so I wouldn't want to trouble you to bring it and then I don't show up.

I haven't decided exactly what I want to do yet. I was hoping I'd find a replacement ready to go and then rebuild the old one for a spare but I haven't found one with a speedo output to fit a 2000 LT yet.

I will keep your loaner offer in mind and will gladly trek across town to borrow it if I decided to go down that path. Thanks again.
 

·
Registered
Joined
·
719 Posts
Discussion Starter #5
edmann said:
curious, how many miles on your bike?
not much, about 45k.
 
1 - 5 of 5 Posts
Top