BMW Luxury Touring Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
392 Posts
Discussion Starter · #1 ·
Was on the way to dealer, about 250 miles away, to get fork seals replaced, when the ABS lights started to flash. In the past, they would do this when I started a trip. Simple solution was to shut the bike off, re-start and the system would re-set itself. This time no go. Dealer had only a minute to look it over. He did a load test on the battery, and it checked out good. The pads were replaced, as the fork oil had drenched them. I got home & toped off both brake fluid containers. Still the ABS is flashing. Dealer, Hansens of Medford, said they had developed a few tricks to fix the problem, but sometimes none of those worked & the owner had to chose to live with it or start replacing some very expensive components. Could the fork oil leaking have contaminated the ABS sensor, and if so how is it possible to remove, & or clean it? I have never worked on the brakes on this machine. It is a 94 K1100LT with nearly 70k on it. Any advice would be appreciated.
Thanx.
 

·
Registered
Joined
·
223 Posts
Here's a very useful synopsis of the collective wisdom from the K11 rider's group (K11OG.org) that you should read, and then perhaps raise your issues on that forum:
http://k11og.org/forum/viewtopic.php?t=2110

I personally am a "tweener," as I have both a K12LT with the integrated brakes and a 71K75 RT; And so I have confidence in both the folks here on this forum and those on K11OG

Larry Johnson
2003 K12LT
1991 K75RT
(and tomorrow, a 1993 K11LT)
 
1 - 2 of 2 Posts
Top