BMW Luxury Touring Community banner

1 - 10 of 10 Posts

·
Registered
Joined
·
478 Posts
Discussion Starter #1
did winter service a while back finaly got nice enought to ride her. when i took her out for a ride i get a slight antifreeze odor when i take off from a red light. seems to be from the left side. dose not seem to be leaking.
other than not getting the cap on correctly when i changed antifreeze.(nasty piece of buissness with tank on) any other suggestions
 

·
Registered
Joined
·
4,241 Posts
did you spill some? is the cap on right now? what is the level in the overflow reservoir?
 

·
Registered
Joined
·
478 Posts
Discussion Starter #3
i did spill some but have ran the bike in the shed a bit . first time fan cycled it steamed out a while. some may have got on the engine but i have run the bike several times.residual should be gone i think. i am gonn try to take the cap off later today for inspection.level seems normal
 

·
Registered
Joined
·
1,106 Posts
What Michael said.

And, I spilled some and the engine smoked and smelled when I first fired it up. After it burned off everything was OK. I too, did not remove the tank, that was why I spilled some. :eek:
 

·
Registered
Joined
·
478 Posts
Discussion Starter #6
yes my fuel tank was on it was very difficult to r&r the cap. that is what is making me think the cap may not be on correctly
 

·
Enjoy The Ride
Joined
·
3,976 Posts
I spilled a little the last time I changed my anti-freeze & it took several days of riding for the smell to go away.
 

·
Registered
Joined
·
3,137 Posts
Bob, you may just have a case of expansion and overflow from the expansion tank. I have had similar smells in warm weather after doing a coolant flush and fill.

John
bobst2 said:
just checked level in sight glass. it is a little below max line when cold
 

·
Registered
Joined
·
2,746 Posts
When I changed the antifreze in mine I got the bit o honey smell for the first few rides and then it went away

Loren
 
1 - 10 of 10 Posts
Top