BMW Luxury Touring Community banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a new to me 99 LT that has the hesitation while leaning in hot weather. I did quite a bit of searching on here regarding the issue, and decided to pull the Intake air temp sensor last night. I also read that pulling the air temp sensor along with pulling a certain relay could result in damage to the engine. Any way that I can check to make sure that the PO did not pull this relay? Also, is there any chance that my local dealer would replace the ECM with the updated version so that I can plug the air temp sensor in and still get good performance?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,534 Posts
That bad thing was cutting the "brown wire" and "pulling the air temp sensor". The 99s do not have the brown wire. So you are good.
 

·
Registered
Joined
·
5,857 Posts
But the 99 - 01 do have the cat code plug under the trunk and you do not want both the air temp sensor and the cat code plug pulled at the same time.
You can check your cat code plug by removing the trunk and the rear cover under the trunk.
 

·
Registered
Joined
·
253 Posts
Finally things make sense :) I have a 99 and was wondering why my LT doesn't hesitate at hot temperatures while the airbox temperature sensor is connected.

But I do observe some brown wire running on the right side under the rider seat. I thought this was the brown wire.
 

·
Registered
Joined
·
2,746 Posts
There are lots of brown wires on all year LT's. Brown is ground (earth) on these bikes.

The '99 just doesn't have THE brown wire in question.

Loren
 
1 - 5 of 5 Posts
Top