BMW Luxury Touring Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
82 Posts
Discussion Starter · #1 ·
My 2730 will intermittently start clicking and, if it's in Map mode, the screen will flash and jump to the highest enlargement position. In XM mode, the stations will begin switching randomly. There is no common temperature or humidity condition ... hot, cold, wet, dry doesn't seem to matter. It does this in my car and on the LT. This doesn't happen every time, and there's no way to predict it. When this happens in Map mode, I can switch to XM and the station remains locked in. The only remedy I've found is to shut it down, then restart it again. The unit otherwise operates for long periods of time with no problem.

Have you had any similar experiences or what can be done about it?
 

·
Just ridin'
Joined
·
5,297 Posts
BMWCharlie said:
My 2730 will intermittently start clicking and, if it's in Map mode, the screen will flash and jump to the highest enlargement position. In XM mode, the stations will begin switching randomly. There is no common temperature or humidity condition ... hot, cold, wet, dry doesn't seem to matter. It does this in my car and on the LT. This doesn't happen every time, and there's no way to predict it. When this happens in Map mode, I can switch to XM and the station remains locked in. The only remedy I've found is to shut it down, then restart it again. The unit otherwise operates for long periods of time with no problem.

Have you had any similar experiences or what can be done about it?
Probably an intermittently bad touch screen. The only option is to return it to Garmin for repair. They have been known to replace them under warranty - even beyond the standard warranty.
 

·
Premium Member
Joined
·
5,852 Posts
Randy said:
Probably an intermittently bad touch screen. The only option is to return it to Garmin for repair. They have been known to replace them under warranty - even beyond the standard warranty.
I had exactly the same behavior, some days it was good some day it was bad, as if the wind was actuating the touch screen, or the vibration or who knows. But Randy is right, call Garmin and try to get it replaced in warranty. there is nothing else you can do.
 

·
Registered
Joined
·
1,514 Posts
I was having some probs with my 2610 and I think it was the infared sensor ( for the remote) I turned it off never had any probs since dont need it on the Lt anyway, maybe you could try that??
 

·
Registered
Joined
·
82 Posts
Discussion Starter · #6 ·
I just spoke to the Garmin factory service rep. For $225 minimum they'll look at it. Thanks but no thanks. Don't know who you got at Garmin to fix it for free, but my lady was no help at all without my checkbook. I'm going to live with the problem.
 

·
Registered
Joined
·
539 Posts
Clean your screen - My 2730 did that a couple of times - When I carefully cleaned the screen - it stopped. Maybe touching it (cleaning) on the entire screen helped.

Steve
 
1 - 7 of 7 Posts
Top