BMW Luxury Touring Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
So, I take my bike down to Blackfoot motorcycle and have them complete a 20K service. On the way home I stop for fuel and realize my reverse isn't working. Next day back into Blackfoot to get checked out only to be told that their moditech showed that the "control unit - backup" was the problem and it would cost me nearly $1400 for the part plus labor (YIKES) to get it fixed. I know reverse worked when I dropped it off with them for the service because I used it in their parking lot. Anybody have any thoughts on what might have happened during the service to cause the failure?. Light comes on but nothing else. Also, any words of wisdom on where I might get a deal on a "control unit - backup". Would really appreciate any advice .
Thanks
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
13,946 Posts
There is nothing that I know of that even touches the reverser during a standard service. Looks like you won the failure lottery. The controllers have been known to just "fail" for no good reason. But I would look at the rear of the battery for a tie point with large black wires with yellow stripes for one that may be missing. But if the rpm does not go up when you press the button I would suspect the controller.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Thanks John, I'll check the wiring near the battery. I guess I was kind of hoping there might some other reverser wiring that might have been affected when the tupperware came off for the valve adjustment etc. Looks like I might have to bite the bullet for a new controller.
 

·
Registered
Joined
·
577 Posts
+1 on the wire connections. While my symptom was a little different, reverse would only work for a few feet, and then needed to have a new press of switch and do a few more feet. As I was on a long trip and everything else was working I said I would take it yo MAX in New York when I got home.

Short of it is, they found loose connection wire, inserted same and have not had a reverse problem in last 20 K miles. They said wire connection was on the under side of bike.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Keeping my fingers crossed that it is simply a wiring issue but, preparing for the worst..
 

·
Registered
Joined
·
158 Posts
Before letting Blackfoot do the work I would take it to AnderWerks and have them check the bike. I find the service much better than Blackfoot and Dave is extremely knowledgable regarding the K bikes.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
Thanks Ken, I know Dave and talked with him on Friday. He used to do the work on an 80/7 that I had. I would have taken my LT to Dave in the first place but I had to have some warranty work done. My Voice Com failed and even though my bike is technically out of warranty, BMW picked up the cost of the VC (it was an intermittent problem since new) but I had to pay labour and it only made sense to do it at the same time as the 20K service. Now that warranty is over Dave will be the guy.

Thanks again
 
1 - 7 of 7 Posts
Top