BMW Luxury Touring Community banner
1 - 4 of 4 Posts

·
Registered
Joined
·
216 Posts
So I went ahead and spent the extra $500+ to get the Alpine radio module for my RT to have XM as an option for music.
However the RECEPTION IS HORRIBLE - I get 2-3 seconds of music followed by 15 seconds or more of silence as it loses signal CONSTANTLY.

Does anyone know of a BMW fix for this?
I know I can go SPEND MORE money to get an aftermarket antenna and relocate it to the top box, but I'd rather it be integrated like BMW meant it to be.

GS911 scan info of bike and that module is as follows (need 2112.04 GS911 software) :

Bike Information : -
VIN : WB10L0302M6E68754
Model : R 1250 RT (K52)
Factory I-Level : K001-21-03-505
Actual I-Level : K001-21-11-500
Backup I-Level : K001-21-03-505



UNKNOWN : -
Controller Type : Unknown
Controller Name : UNKNOWN
Controller : 0x0F8910
Serial Number : 0000611508
Manufacturer : Alpine GmbH
Manufacture Date (YY/MM/DD) : 21/06/01
Firmware Date (YY/MM/DD) : 21/06/01
Kilometers when programmed : 0.00
Number of FW configurations : 7
HW Electronics (HWEL) :
Firmware ID : 0x64DE
Firmware Version : 004.003.000
Bootloader (BTLD) :
Firmware ID : 0x0006
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7862
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7863
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7864
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7860
Firmware Version : 004.000.001
Coding Data (CAFD) :
Firmware ID : 0x64E0
Firmware Version : 003.000.014
Ironic how BMW listened to riders who hated the radio antenna sticking out and hid it under the fairing. Of course, this is why XM reception no longer works.

I have a good friend who was all amped up to get a new RT with the TFT. Until he found out how BMW implemented the infotainment system. What does he have now? A 2020 Goldwing Tour DCT. He was a long time BMW owner. BMW's new TFT/Infotainment is so bad they are losing customers.
 

·
Registered
Joined
·
216 Posts
The XM signal has nothing to do with the new TFT - someone posted in another thread that XM signal works very well in the new R18 which has the same TFT as the RT. The antenna component or its positioning is to blame. There are also older threads in the forum related to previous RT models and complaining of XM signal issues - so issue was not introduced with the new model (nor fixed)
I know it has nothing to do with the TFT itself.
 

·
Registered
Joined
·
216 Posts
So I went ahead and spent the extra $500+ to get the Alpine radio module for my RT to have XM as an option for music.
However the RECEPTION IS HORRIBLE - I get 2-3 seconds of music followed by 15 seconds or more of silence as it loses signal CONSTANTLY.

Does anyone know of a BMW fix for this?
I know I can go SPEND MORE money to get an aftermarket antenna and relocate it to the top box, but I'd rather it be integrated like BMW meant it to be.

GS911 scan info of bike and that module is as follows (need 2112.04 GS911 software) :

Bike Information : -
VIN : WB10L0302M6E68754
Model : R 1250 RT (K52)
Factory I-Level : K001-21-03-505
Actual I-Level : K001-21-11-500
Backup I-Level : K001-21-03-505



UNKNOWN : -
Controller Type : Unknown
Controller Name : UNKNOWN
Controller : 0x0F8910
Serial Number : 0000611508
Manufacturer : Alpine GmbH
Manufacture Date (YY/MM/DD) : 21/06/01
Firmware Date (YY/MM/DD) : 21/06/01
Kilometers when programmed : 0.00
Number of FW configurations : 7
HW Electronics (HWEL) :
Firmware ID : 0x64DE
Firmware Version : 004.003.000
Bootloader (BTLD) :
Firmware ID : 0x0006
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7862
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7863
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7864
Firmware Version : 004.000.001
SW Memory Image (SWFL) :
Firmware ID : 0x7860
Firmware Version : 004.000.001
Coding Data (CAFD) :
Firmware ID : 0x64E0
Firmware Version : 003.000.014
Get a pre-2021 RT? Not really. The XM reception on my 2019 is great but the audio quality through my Sena headset is awful. Like AM quality awful. So bad that I haven't used it since May 2019.
 
1 - 4 of 4 Posts
Top