BMW Luxury Touring Community banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
It's been a long time since I posted anything here, but I'm hoping for some wisdom/advice on a throttle issue. A long post, so please bare with me.

I have the 09 LT with 36K+ miles, bought new and serviced almost totally at the dealer, except oil changes, always garaged, except on trips of course so it has had some rainy nights uncovered, but overall in good condition, and not road too hard, much. That was a long sentence.

Anyway, I'm getting a very sticky throttle; actually sticks open while riding but will slowly close if I let go, during longer trips where I'm doing 300 to 500 mile days in temperatures raging from 40 F to 90 F, but when the bike is cool and on short trips, no sticking, the throttle will snap back to closed relatively quick. Does this sound like bad throttle cables, possibly cable adjustments or maybe something down in the throttle body, actuator or sensor?

Any advice or knowledge is appreciated, thanks, Matt
 

·
Registered
Joined
·
1,504 Posts
I wouldnt think it has anything to do with adjustment the clue is the temp If it were mine I would remove the LHS plastic and check the cable locations, there is something swelling up with the heat and jamming something. if it were cables they would be stiff all the time, could be in the hand grip but I would doubt it. sorry cant help good luck Matt let us know what you find
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Axle, sounds like a good bet to check the cable location and the possibility of heating issues. I think I'll give it a try this weekend.

I love riding this bike, but the maintenance cost can be a bit daunting. Guess I'll have to quit being lazy and do more of the maintenance myself...maybe.

Thanks, Matt
 
1 - 3 of 3 Posts
Top