BMW Luxury Touring Community banner

1 - 12 of 12 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
I have an '09 LT with the Nav IV system installed on it. When getting directions to a location, I see the route I should take but there is no audio coming through the radio. The manuals don't seem to indicate what should happen so I thought I would ask on this forum. Does anyone know if I should be able to hear turn by turn directions through the radio?

Thanks,

Eric
 

·
Registered
Joined
·
203 Posts
Eric, I dont think you can hear it through the speakers. I always have my helmut headset on when listening to navigation. Someone will let you know for sure...
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
fwkraft,

I have a helmet handset and don't hear anything from either it or the speakers. Just trying to figure out whether to return it to the dealer for fix or not.

Thanks,

Eric
 

·
Premium Member
Joined
·
7,800 Posts
I don't have the same setup you do, but when I run a Zumo 550 off its internal battery there is no audio. It's designed that way. Once I connect it to the bike or car battery the prompts are there.
 

·
Registered
Joined
·
83 Posts
Eric,
I have an 09 and I bought the Navigator 3 plus. No voice prompts on the bike through headset or speakers. When I put it in my car, the voice prompts work fine. Dealer couldn't figure it out either. Contacted Garmin CS by email and they said that the bike may have been wired incorrectly during the dealer install. Garmin also said that if the dealer has another unit that is working, to have them try that unit on the bike and if it works, Garmin will take the unit back and replace it or fix it. I'm not scheduled to go in for another service for a couple of months so I'll tell them the Garmin info then. I actually hate the voice prompts when it's in the car...that "Karen" beoch won't shut up...but I think it should work and let me have the choice anyway. It might come in handy say in NYC or another big city where I don't have much time to keep looking at the screen. Good luck.
 

·
Registered
Joined
·
21 Posts
Do you have the J&M intercom audio system? With that properly wired you should get the audio from the Nav system through your headset. Mine works perfectly. I am just trying to figure out if I can have my phone attached on bluetooth through the nav system and still hear and voice dial. Still haven't played with it yet...
 

·
Premium Member
Joined
·
1,481 Posts
I have a 2007 LT with Nav IV and I hear the directions through my helmet head set. My pillion passenger does not hear them and if we're talking via intercom, the Nav will interrupt the conversation (she is unaware of the interruption). Fortunately, as with most women, she just keeps talking anyway and I can just pick up on the conversation when the Nav is done. :D

If you aren't getting audio directions, something is wrong with the unit, the wiring or your settings.
 

·
Registered
Joined
·
51 Posts
so if I read this right, you should obviously hear the voice commands from the GPS through a headset, but not through the external radio speakers, EVER. Correct?

Had the dealer install the Comm II and I just completed a home install of the Nav IV yesterday, and hear nothing through the speakers. Don't have a headset yet, so I'm not complete, but just checking to be sure.
 

·
Registered
Joined
·
453 Posts
Hi, I think the manual for the Nav IV doe tell you what you can expect for the audio / mount. I think it is closer to the end of the manual - it is in the form of a table, but it is buried deep within.

In short, for audio / motorcycle mount it will transmit bluetooth audio only. The ZUMO 660 has an audio lead which will take a headset or even link to the speaks (Not sure because I have a Nav IV myself.)

Hope this gives you an answer and possible solution.

Best regards
Sleuth
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Thanks everyone for your responses. This is awesome! As I stated, I have an '09 with the Nav IV system. I just got the bike about 3 weeks ago and also got the Comm II system (part of the BMW promotion). I also have a headset which is working properly. My dealer did all of the install and it sounds like I need to return to them to fix this. It's time for my first service (ouch I understand) so when I return it for that, I will have them correct this oversight. If anyone knows of a way I can go after it, I'm all ears (so to speak).

Thanks again!

Eric
 

·
Registered
Joined
·
48 Posts
I purchased my 09 LT last December and also got the COM II along with the Nav IV. Since I was unable to listen to any MP3's through my headset, or pair my iPhone with the unit, I called Garmin and after about four calls I finally talked with an IT person who told me there was a software / firmware problem with the NAV IV (660) and they didn't know when and if Garmin was going to address it. I explained that a friend had just purchased the 665 so I placed it in my cradle and the unit worked flawlessly.

To make a long story short, Garmin upgraded me to a 665 which now also gives me XM which I will subscribe to next year. On a quick note after getting the 665, I played around and found the none of the 4 buttons on the cradle worked so I removed and installed the cradle that came with the 665.

On a quick note: If you find that you are having problems, before you give up your NAV IV, go into it and copy the BMW locator so that you can add it to the 665. I thought it was pretty cool having all the BMW shops locations especially since I do a lot of road trips. Good luck
 
1 - 12 of 12 Posts
Top