BMW Luxury Touring Community banner

1 - 20 of 22 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #1
Haven’t posted for eons but need some help please. I’ve done some searching of the forum with no joy.

My LT with a build date10/03 has both the Warning Light and the Brake Failure light on solid from start up and while riding with the following –
Speedo not working
Cruise Control not working
Brake lights don’t work, and
Brake assist does not work

The brake servo pump does not run when I apply either brake.

I’ve checked all the fuses under the seat but I am now out of ideas.

Anyone experienced this or similar?
 

·
Wrencher Extraordinaire
Joined
·
13,774 Posts
Since that pattern of light does NOT appear in the failure guide and that the speedo, cruise and brake lights are not working (which all run through the ABS) it sounds like your unit is DOA. Could be caused by some corrosion on the big connector to the ABS. You could try "jacking" the connector a few times (remove and install). It is fairly easy to get to on a 2003, just stick a screw driver in the rounded end and lever it out wards and it will lift the connector off the unit. Reverse to install. If that does not produce a change I am afraid you ABS brain is dead.
 

Attachments

·
Registered
Joined
·
234 Posts
Discussion Starter #3
Hmm... doesn't sound good.

I've read on the forum about the Second Life Kit but couldn't find any other information on it through the search feature.

Has anyone installed one?

My LT is low milage and in very good condition but useless until I find a solution.
 

·
Wrencher Extraordinaire
Joined
·
13,774 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #5

·
Registered
Joined
·
234 Posts
Discussion Starter #6
After reading some of the older posts on farkles (spurred on by Ari's return), I now realise why my ABS failed - I don't have a gremlin bell. :surprise:

I just ordered one on eBay, I'm not going to chance it again!
 

·
Registered
Joined
·
3,206 Posts
After reading some of the older posts on farkles (spurred on by Ari's return), I now realise why my ABS failed - I don't have a gremlin bell. :surprise:

I just ordered one on eBay, I'm not going to chance it again!
Geez... maybe I should attach mine, instead of sitting on my bedside cupboard!!! :histerica:histerica


now I’ve jinxed myself, just as I’m about to bleed the brakes and ABS unit! :surprise:
 

·
Registered
Joined
·
8 Posts
The problem is the pressure sensors the will give the wrong input they are hard to repair I sent my abs module 2 times for repair no result. No I will bypass the system by emulator-abs first picture the pressure sensor second picture the bypass unit with modified electronics
 

Attachments

·
Registered
Joined
·
234 Posts
Discussion Starter #9
. Now I will bypass the system by emulator-abs.......bypass unit with modified electronics
Is that the Second Life kit by RH Electronics? or another unit?

I'm waiting for the delivery of one from RH Electronics at the moment.... but the mail sucks right now.
 
  • Like
Reactions: beech

·
Registered
Joined
·
94 Posts
The problem is the pressure sensors the will give the wrong input they are hard to repair I sent my abs module 2 times for repair no result. No I will bypass the system by emulator-abs first picture the pressure sensor second picture the bypass unit with modified electronics
So they never got it to work? I thought there was a German shop the could rebuild them, even though it was quite pricey.
 

·
Registered
Joined
·
9 Posts
Hi, I didn’t have the exact same problem but had those warning lights on with no brake lights. There is another relay under the plastic on the drivers side. After $350 of diagnosis in Sarasota, with no outcome, I researched and found out about this relay and had them change it in Scottsdale(along with the air filter and spark plugs as they had it apart). Solved my problem.....
 

·
Registered
Joined
·
8 Posts
Maybe your right with the German company. It's half price compare an new abs unit. I bypasses the system with a emulator-abs mod. It's really nice to see how they maked the bypass system and modify the electronic for brake lights, speedometer and warning light in the dash. And you keep the original brake. lines
 

Attachments

·
Registered
Joined
·
234 Posts
Discussion Starter #13
Maybe your right with the German company. It's half price compare an new abs unit. I bypasses the system with a emulator-abs mod. It's really nice to see how they maked the bypass system and modify the electronic for brake lights, speedometer and warning light in the dash. And you keep the original brake. lines
Who makes this bypass system? Do you have a web address?
 

·
Registered
Joined
·
234 Posts
Discussion Starter #15

·
Registered
Joined
·
8 Posts
This afternoon the first km with the bypass system, the brakes are good but very different as with the pumps and very different as without pump its in between.
The brakes works good but you have to use the other brake feeling.
 

·
Registered
Joined
·
1 Posts
I have a similar issue, warning light on, brake light flashing, some times just brake light. some times I ride all day, no issues, yesterday after 50 mi. light flashing, the GS 911 says its the rear brake switch, let GS911 run full test, brake light stayed on during first test, not second. replaced with good used switch, no help. today I pulled tank and replaced brake light relay. hard to trouble shoot when everything is working. Casper where are you?
 

·
Registered
Joined
·
234 Posts
Discussion Starter #19
Still waiting for my Second Life Kit.

It was posted in Germany at the beginning of the month and has been sitting in Frankfurt "cleared and waiting International departure" for over three weeks now.

F^(&#@ Ccvid19!
 

·
Registered
Joined
·
234 Posts
Discussion Starter #20
Still waiting for my Second Life Kit.

It was posted in Germany at the beginning of the month and has been sitting in Frankfurt "cleared and waiting International departure" for over three weeks now.
My Second Life Kit has been sitting in Germany for a month waiting for a flight to Australia. Today the Post Office notified me that it now will now be shipped from Germany to Australia by sea...... I guess another month of waiting..... :crying:

For the Aussies out there - NOT HAPPY JAN!
 
1 - 20 of 22 Posts
Top