BMW Luxury Touring Community banner

1 - 11 of 11 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi, I have a 2000 1200lt and the clock and gear witnesses or indicators are almost gone, can't see them but blurry digits.

Is there anything to fix them, do I need to change them?

Thank you!
 

·
Registered
Joined
·
343 Posts
My radio display was hazy where it was difficult to read the letters. A forum member suggested Denatured Alcohol and a cotton swab. It worked perfectly. I purchased a can from my local hardware store.

Rob, 2000LT
Navarre, FL
 

Attachments

·
Registered
Joined
·
1,514 Posts
photo please !! the unit could be replaced I had mine out this past weekend or is it the outer plastic causing the problem
 

·
Registered
Joined
·
1,514 Posts
there are 11 clusters posted on ebay presently, buy one and put your speedo into the replacement cluster
 

·
Registered
Joined
·
21 Posts
Discussion Starter #7
Hi guys,

here are the pictures of both the radio and the gear display.

any ideas on how to fix them?

thank you.
 

Attachments

·
Registered
Joined
·
21 Posts
Discussion Starter #8
My radio display was hazy where it was difficult to read the letters. A forum member suggested Denatured Alcohol and a cotton swab. It worked perfectly. I purchased a can from my local hardware store.

Rob, 2000LT
Navarre, FL
hi rob, i'll check if i can get it here. hopefully it will work at least with the radio, im still missing the gear display.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Yeah, it would be nice to be blurry. Mine is missing digit segments on watch and gear. How do we repair this?
actually mine has the same issue... does it look like mine?
did you get a way to fix it?
 

Attachments

·
Registered
Joined
·
343 Posts
hi rob, i'll check if i can get it here. hopefully it will work at least with the radio, im still missing the gear display.
I'm confident the denatured alcohol will work with your radio display. Mine had the same appearance as yours before I used the alcohol. As for the missing segments on your gear display, I'm at a loss. I'm sure one of the forum wise ones will chime in with a suggestion.

Rob, 2000 LT
Navarre, FL
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
14,246 Posts
Try Google "fix LCD display". There were several there none of which were as comprehensive as I would have liked. Two things cause this. Failure of the ribbon cable to LCD "sandwich" and failure of the "sandwich" itself. The links will help with the cable but the sandwich is not well described. The LCD is connected via silicone strips with flexible conducting lines in them. They make the contact from the electrical board to the glass LCD display. Often just taking it apart and cleaning up the contacts on the electrical board (pencil eraser) and re-assembling the sandwich holder will fix missing pixels. Here is one good source for how they are hooked up.
 
1 - 11 of 11 Posts
Top