BMW Luxury Touring Community banner

1 - 6 of 6 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
A very non-tech description of the problem:

My 1997 r1100rt turn signal fuse has blown twice. After the second blown fuse I stopped using the turn signals when I noticed that a blown turn signal fuse also disables the wind screen motor. The windscreen motor continues to work normally and has not caused a blown fuse. Consequently the windscreen motor and wiring can be eliminated as the source of the problem. I suppose it might be something else besides the turn signals, but I do not know what else is connected to that fuse.

Any suggestions as to what might be the problem and/or how I might pinpoint the problem?

Thank you in advance for your interest and assistance.
 

·
Registered
Joined
·
38 Posts
Discussion Starter #2
I should clarify that after the second blown fuse I did of course put a third new one in, but at that time I stopped using the turn signals.
 

·
Registered
Joined
·
2,811 Posts
How about a pinched or worn through wire somewhere on the turn signal path? Need to do a wire trace for pinch points. Worst case the wire is broken inside the insulation at a tie rap or something. Check the bulb socket area first.
 

·
Registered
Joined
·
2,811 Posts
You could even check by un plugging connectors (once you find them) for either end and seeing if the problem is in the wire or light beyond the connector by trying a fresh fuse. Go low amps as you are not driving the windshield motor.
 

·
Registered
Joined
·
444 Posts
beech said:
How about a pinched or worn through wire somewhere on the turn signal path? Need to do a wire trace for pinch points. Worst case the wire is broken inside the insulation at a tie rap or something. Check the bulb socket area first.
+1. I installed some bar backs on a friend's '99RT recently and the tie that holds the wires on the handle bars was so tight and cover brittle that it had cut through to the wire. Check the underside of the handle bars first.
 
1 - 6 of 6 Posts
Top