BMW Luxury Touring Community banner

1 - 2 of 2 Posts

·
Registered
Joined
·
835 Posts
Discussion Starter #1
Hi all, I have a plain 1985 R80, several things happening, after putting on trickle charger thru the accessory plug the bike won't start. I do not know if there is a relation between trickle charging or problem, could just be coincidence. All lights work, turn signals and horn brake light etc.. However, the neutral light and oil light do not come on and when I push starter button absolutely nothing happens. I have replaced batery and starter relay. It appears that there is a good bit of oil on what I believe is the neutral switch underneath. The switch looks difficult to get to but found a good paper on how to replace it.

My question is could the neutral switch be my problem. It does not matter if clutch is pulled in or not, I get nothing at starter button. If not what else, yes I have checked the fuses.
 

·
Registered
Joined
·
289 Posts
well, this can be anything. I got myself a special book for R-models after getting myself a R80ST as rebuilder during the times that I do not ride the K1200LT.

In my book, under, starterengine does not run, is stated:
- emergency switch is not on run
- mainfuse is broken
- battery voltage too low
- gearbox is not in neutral
- defective emergency switch
- broken, durty switches
- defective neutral switch
- defective starter relay
- defective starter button
- shortcut in wiring
- defective startermotor

So, also the books do not help much. You have to work some bits to eliminate the problem.
 
1 - 2 of 2 Posts
Top