BMW Luxury Touring Community banner
1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
OK, purchased LT last August from the list member. Didn't notice when I bought it that rear speakers worked sporadically. Turn radio on, rear speakers USED to stay on for 30 seconds, then 10-15 seconds, then right would cut out, then left or vice versa. Now neither comes on and now right front speaker does come on then goes off and that happened just today!!. I've scanned list for similar problems-similar but not the same; I've disconnected battery to reboot - no effect. Checked FAD and BALANCE -they work but still no right front or rear speakers. I've cleaned barrel connectors under rear seat- no effect. All other functions work just fine-BASS, TREBLE, FAD, BAL. Speaker function is ON. CD (same speaker problem on CD). I have a Baehr radio/com system and have disconnected the barrels but same problem whether connected or not. Any help appreciated before expensive trip to dealer!!

http://www.bmwlt.com/forums/images/icons/icon9.gif
 

·
Registered
Joined
·
498 Posts
Before spending a nickle, I would clean your connections. The majority of the problems you are describing are common. I would remove your rear seat an clean AND protect (dielectric grease) the two QDs under there, the front speaker QDs are under the left side of the stingray, and the main radio harness under the radio pod.
Sounds like a pain, but it may save you a trip.....
 

·
Registered
Joined
·
498 Posts
edmann said:
Before a trip to the dealer I would check and clean the connections from the stingray. It is easy to do but require removal of the fairing sides and center console.
BEAT ME TO IT!
 

·
Registered
Joined
·
659 Posts
Cochinosucio said:
BEAT ME TO IT!
I'm inclined to believe the amp is going out.
 

·
Registered
Joined
·
45 Posts
Ive posted this question before and never got an answer, but can I replace or upgrade the amp and maybe speakers with the stock radio to get some better sound out of the speakers?
 

·
Wrencher Extraordinaire
2005 K1200LT
Joined
·
15,061 Posts
The amp is not separate from the radio, it is all one unit less the controller (directly under the buttons). Once all this starts to go you are better off going to a Jensen Marine both cost wise and sound wise. The speakers are usually just fine.
 

·
Registered
Joined
·
593 Posts
I am wondering how much work it is to remove the stereo (stingray?) from my 05? can I put it back together and ride without the stereo unit?
 

·
Registered
Joined
·
169 Posts
I have the same symptoms with an 05 LT will be gutting the radio shortly. With the recent purchase of a Sena headset the stingray will become a much bigger and practical glove box in my opinion. Less than $200 and no wires. (Other then the headset inside the helmet)
 

·
Registered
Joined
·
593 Posts
If you are going to get rid of your factory stereo i would like to have it please. I will even pay for shipping. Please PM me. Thank you
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top