BMW Luxury Touring Community banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Just picked up an 05 KLT. I have done the best I know to find a related thread and the closest I found involves the Lock and the short screw. My lock works just fine, but the latch button sticks in the down position when opened. I have tried looking for the short screw as well as cleaning, and lubricating but it just seems to want to stay down. I can only get it to come back up manually with the surround off or with the key in the lock with the surround on. I have yet to take off all the tupperware to gain more access to the latch.

Is this a common problem? The previous owner says it's been this way since he bought it in 06. Has anyone experienced this? Is there a simple (or difficult) solution short of replacing the latch?

Thanks

Matt
 

·
Premium Member
Joined
·
7,795 Posts
Howdy, Matt.,
Welcome aboard!

My "latch" kinda hung a few times.. I found the small center cover, that surrounds the button, when removed allowed the button to move freely. Careful review showed where the button was "hanging" against the cover. A slight "sanding" on the inside of the cover and careful installation (don't overtorque the screws) had it working just fine.
 

·
Registered
Joined
·
929 Posts
+1 on the light sanding...

Welcome to the forum Matt--I would encourage you to search the technical section--you would want the HALL of WISDOM found there. Great reading!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
cfell said:
Howdy, Matt.,
Welcome aboard!

My "latch" kinda hung a few times.. I found the small center cover, that surrounds the button, when removed allowed the button to move freely. Careful review showed where the button was "hanging" against the cover. A slight "sanding" on the inside of the cover and careful installation (don't overtorque the screws) had it working just fine.

Do you mean the body color surround? I've had that off and it still sticks with it off. If you mean the black part surrounding the lock, I'm not sure how to get that off. any clue?

Thanks

Matt
 

·
Premium Member
Joined
·
7,795 Posts
Matt,
Mine was sticking with the color trim piece on.. I removed the trim and the button worked well.

If yours doesn't.. different problem.... and I would have asked the dealer to resolve during warranty.

Since that doesn't appear to have happened, I'd imagine there is a problem in the internals. Of course this is conjecture since I can't see the bike/problem.

I would spritz some "silicone" spray in the slide portion of the button... not inside the lock.

Also, try loosening the screws holding the latch button assembly to the bike... you can get better access when you remove the seat (it is mounted to that assembly)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
cfell said:
Matt,
Mine was sticking with the color trim piece on.. I removed the trim and the button worked well.

If yours doesn't.. different problem.... and I would have asked the dealer to resolve during warranty.

Since that doesn't appear to have happened, I'd imagine there is a problem in the internals. Of course this is conjecture since I can't see the bike/problem.

I would spritz some "silicone" spray in the slide portion of the button... not inside the lock.

Also, try loosening the screws holding the latch button assembly to the bike... you can get better access when you remove the seat (it is mounted to that assembly)

Thanks for the seat mount tip. I've tried a number of lubes and cleaners in there including silicone, antiseize, wd-40 and compressed air (about all that's left is graphite lock oil, but I thought that might not agree with that black plastic, not to mention make a worse mess than the anti-seize. Looks like I'm taking it apart to get better access. It feels like there are plastic parts in there that just don't fit the way they are supposed to as it just sticks at the very bottom of the movement of the button, which might not be a problem if that much motion wasn't required to open the compartment.

Thanks again

Matt
 
1 - 7 of 7 Posts
Top