BMW Luxury Touring Community banner

1 - 4 of 4 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I have been having a problem with the speakers on my 01 LT. crackling after a while. The guy who works on my bike said that it is a common problem with the head unit. I was wondering if anyone here has had the same problem, and what is the best way to solve this. My guy told me the head unit is made by Becker and I would need to get a new unit or take the chance of having a used one doing the same thing. I for one don't think I will get a new one. I am about to get a new helmet and I was going to get a blue tooth unit with it and I can get the I-pod transmitter for it. So in other words, what would you guys and girls do with this problem? I know a little long, but hard to say what is wrong in two lines. Thanks
 

·
Registered
Joined
·
444 Posts
Noggin1970 said:
I have been having a problem with the speakers on my 01 LT. crackling after a while. The guy who works on my bike said that it is a common problem with the head unit. I was wondering if anyone here has had the same problem, and what is the best way to solve this. My guy told me the head unit is made by Becker and I would need to get a new unit or take the chance of having a used one doing the same thing. I for one don't think I will get a new one. I am about to get a new helmet and I was going to get a blue tooth unit with it and I can get the I-pod transmitter for it. So in other words, what would you guys and girls do with this problem? I know a little long, but hard to say what is wrong in two lines. Thanks

Many of us have had issues with our radios. Do a search on Jensen Install. That is how I solved my radio issues.
 

·
Registered
Joined
·
5,857 Posts
Noggin1970 said:
I have been having a problem with the speakers on my 01 LT. crackling after a while. The guy who works on my bike said that it is a common problem with the head unit. I was wondering if anyone here has had the same problem, and what is the best way to solve this. My guy told me the head unit is made by Becker and I would need to get a new unit or take the chance of having a used one doing the same thing. I for one don't think I will get a new one. I am about to get a new helmet and I was going to get a blue tooth unit with it and I can get the I-pod transmitter for it. So in other words, what would you guys and girls do with this problem? I know a little long, but hard to say what is wrong in two lines. Thanks
Common problem - Many have solved this by the use of Dielectric grease on every connection.
This means you will need to take the stingray off and get all the way to the back of the radio unit. Clean every connection from there all the way to the back speaker connection under the back seat. Once you finish cleaning then use lots of the
Dielectric grease on all the connections. Then check your antenna at the base to be sure it's connected and tight.
This fixed mine - Good Luck.
 

·
Registered
Joined
·
3,137 Posts
+1. John is right on the money here! I have had episodes of "crackling" in my headset and everytime found the culprit to be moisture in some of the many connectors you have on gthe Stingray. This can often happen after you hit s "frog strangler". as Grif calls them. The final cure is to apply the Dielectric grease to every connection liberally!

John
amarider said:
Common problem - Many have solved this by the use of Dielectric grease on every connection.
This means you will need to take the stingray off and get all the way to the back of the radio unit. Clean every connection from there all the way to the back speaker connection under the back seat. Once you finish cleaning then use lots of the
Dielectric grease on all the connections. Then check your antenna at the base to be sure it's connected and tight.
This fixed mine - Good Luck.
 
1 - 4 of 4 Posts
Top