BMW Luxury Touring Community banner

1 - 12 of 12 Posts

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #1
My LT is still at the BMW dealer (because she wouldn't start.)

They found carbon build up; enough that two exhaust valves didn't fully close.

They have removed the head, cleaned out the carbon deposits and found a valve in one of the functioning cylinders that had a couple of nicks on the valve stem. Apparently, BMW of North America doesn't have the valve. The dealership asked for an expedited order.

Fortunately, they won't have to send the head out for machining.

Once they get her running, they have to deal with a possible slave cylinder leak and maybe replacing the clutch from the leak?

Looks as if this is going to drag out.

Best from Tucson
Bob
 

·
Registered
Joined
·
929 Posts
Sorry to hear about your troubles Bob...hope they get her running soon.
 

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #4
No joy with the valve arriving from Germany.

They are insistent that they will not start on replacing the slave cylinder until they finish getting her running.

Best from Tucson
Bob
 

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #6
Hi Dan

Thanks for the offer

The new valve should be here soon?

Best from Tucson
Bob
 

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #8
80F, sunshine, blue skies, no wind and I'm in a rented car.

I'm still waiting to hear from the dealer if they got her to start. After that, they have to check to see if the slave cylinder is leaking.

My guess is another two weeks after they get her running.

Best from Tucson
Bob
 

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #9
Still waiting.

The new valve arrived; The head is assembled and installed?

During the process they discovered that all four plastic fitting for the return fuel lines were cracked, They ran out of one time uses clamps for the fittings.

Still waiting for parts.

Once they get her running again they will look at the "slave-cylinder"

Best from Tucson
Bob
 

·
Premium Member
Joined
·
3,549 Posts
Discussion Starter #11
I've reserved a car for this weekend.

I called the service department today; got an ans machine; left a message. But, I didn't get a return call.

I'm guessing they haven't got her running yet. That means they won't check out the clutch system until next week at the soonest.

May be they will finish the second week in March?

Best from Tucson
Bob
 

·
Registered
Joined
·
155 Posts
Have you been let out of the cage?
By the time you finish paying for a rental you could have purchased a beater.
 
1 - 12 of 12 Posts
Top