PIAA H7 - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jun 14th, 2019, 2:08 pm Thread Starter
Senior Member
 
EzyMount's Avatar
 
Join Date: Apr 2002
Location: Franklin, NC USA
Posts: 1,347
PIAA H7

Only got about 5200 miles out of this PIAA H7 put in last year !

Guess I’ll be deciding on which LED bulb assy I will be installing next ?

Jim Lawson 2016 R1200RT
Retired to NC !


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
EzyMount is online now  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jun 14th, 2019, 10:17 pm
Senior Member
 
NoelCP's Avatar
 
Join Date: Sep 2015
Posts: 1,662
Re: PIAA H7

Quote:
Originally Posted by EzyMount View Post
Only got about 5200 miles out of this PIAA H7 put in last year !

Guess I’ll be deciding on which LED bulb assy I will be installing next ?
I've had only one bulb failure on my '16 RT w/ 38K miles now. I did change out the original low beam at 14K miles prior to taking a trip even though it was still working as I wanted to learn how to R&R one in my garage versus on the side of the road and figured w/ all of the horror tales of burning out bulbs frequently meant my original was surely going to blow any day now. I replaced it w/ a PIAA and got about 4,200m out of it. I replaced the dead PIAA with a BMW HT Long Life bulb and haven't had a failure yet now in 20K miles. I do honor that internet legend that if you always let the electronics fully boot up before starting the engine you'll reduce lamp burn out significantly.

2016 R1200RT - Dreamliner
2013 F800GT - Sold
1986 Parallel Twin Daughters -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1985 Kawasaki 1000 LTD - Sold
1964 Harley Davidson Sprint 250 - Sold
1968 Honda 350 - Sold
NoelCP is online now  
post #3 of 4 Old Jun 15th, 2019, 12:24 pm
Senior Member
 
6speedTi's Avatar
 
Join Date: May 2012
Location: Ft. Lauderdale, Florida, USA
Posts: 1,025
6speedTi is offline  
 
post #4 of 4 Old Jun 16th, 2019, 12:49 pm Thread Starter
Senior Member
 
EzyMount's Avatar
 
Join Date: Apr 2002
Location: Franklin, NC USA
Posts: 1,347
Put orig factory H7 back in, should be good for another 6k or so..? Took about 10-15 minutes to get out, another 20 or so to get back in and connected.. 🤣 May explore other options later ?

Jim Lawson 2016 R1200RT
Retired to NC !


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
EzyMount is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome