Spark Plug question - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jan 29th, 2010, 5:20 pm Thread Starter
Member
 
Join Date: Aug 2003
Location: , ,
Posts: 50
Spark Plug question

I Have a 1990 K1, would not start, pulled plugs and they were wet (I probably flooded it). But question is, 2 plugs had the little screw on cap installed, 2 didn't. Which way is it supposed to be??

MKG
steeler34 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jan 30th, 2010, 10:58 am
Junior Member
 
Join Date: Dec 2007
Location: Seattle, WA, USA
Posts: 23
Re: Spark Plug question

They should all have the little screw on caps.

93 K1100LT
94 K1100RS
91 K75S
Flying_Duck is offline  
post #3 of 3 Old Jan 30th, 2010, 8:57 pm Thread Starter
Member
 
Join Date: Aug 2003
Location: , ,
Posts: 50
Re: Spark Plug question

Thanks,
went to the dealer andgot a new set (36 bucks) and all had the caps.
Thanks

MKG
steeler34 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Spark Plug repacement without? bulletbill K1200LT 14 Mar 22nd, 2008 7:40 pm
Air Temp, Canistorectomy, Yellow Plug Jabrown K1200LT 10 Jun 22nd, 2007 5:16 pm
Spark Plug question... petevandyke K1200LT 15 Jun 20th, 2007 12:45 pm
Can I find a male plug for this? GaryEdgar K1200LT 7 Jul 19th, 2006 10:09 pm
Spark Plug Question Phil_Adams K1200LT 6 May 14th, 2006 7:36 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome