K1200GT 2003 Died on Road - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jul 7th, 2009, 12:49 pm Thread Starter
Junior Member
 
Join Date: Jul 2009
Location: Cordova, TN, USA
Posts: 3
K1200GT 2003 Died on Road

I was riding down the road about 100 mph. Pulled over for a minute or two, started back up, drove 100 to 200 yards and she died. It turns over great. I don't hear the pump noise.
I got it home, voltage 12.6, took tank off spray starter fuel in air ports, starts fine. I bumped the fuel pump directly to battery, spins.... I'm dying here as to why it isn't getting power when I hit the starter button..... Then I tried last night to bump fuel pump again and nothing... is there a float that doesn't allow it to spin unless it has fuel in it???
All else seems fine.
Please guys any help would be much appreciated...

Only put 1250 miles on her, bought it with 40k.

Thanks in advance,

GBR8465
GBR8465 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jul 7th, 2009, 9:35 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,131
Re: K1200GT 2003 Died on Road

Could be the fuel filter came loose in side the tank. This has happened on many K bikes and produces the same symptoms. There is no float so if the pump does not always run when you feed it with 12 volts direct I would suspect the pump is bad.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is online now  
post #3 of 5 Old Jul 7th, 2009, 10:33 pm
Senior Member
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Re: K1200GT 2003 Died on Road

If fuel pump gets 12v when key turned on, and pump runs, the pump should be ok.

If pump runs a while then stops it could be a bad pump... or a bad / intermittent pump relay... make sure all electrical connections are solid.

Sometimes you can swap relays as a debug tool.

What is your knowledge level on Fuel Injection systems? Have you debugged before?
cfell is offline  
 
post #4 of 5 Old Jul 8th, 2009, 12:17 pm Thread Starter
Junior Member
 
Join Date: Jul 2009
Location: Cordova, TN, USA
Posts: 3
Re: K1200GT 2003 Died on Road

Thanks,
II did remove the fuel pump assy and the darn hoses are all in tack, no cracks...

Could be the fuel filter came loose in side the tank. This has happened on many K bikes and produces the same symptoms.



There is no float so if the pump does not always run when you feed it with 12 volts direct I would suspect the pump is bad

I put 12 volts to it and nothing, bought a replacement pump(used) off ebay and nothing... I touched the leads together an it sparks or has juice.
Sounds like I have to get a new pump....
GBR8465 is offline  
post #5 of 5 Old Jul 8th, 2009, 12:23 pm Thread Starter
Junior Member
 
Join Date: Jul 2009
Location: Cordova, TN, USA
Posts: 3
Re: K1200GT 2003 Died on Road

If fuel pump gets 12v when key turned on, and pump runs, the pump should be ok.

Well the pump does not run..... I turn the key on with volt meter in pump sockets and it reads 12 volts for a second, then a click and the voltage drops to 6 or so..... all this with out hitting the start button....

If pump runs a while then stops it could be a bad pump... or a bad / intermittent pump relay... make sure all electrical connections are solid.

Sometimes you can swap relays as a debug tool.

I did switch the pump relay with the hazard relay since they are the same part number, hazards still working... relay good...


What is your knowledge level on Fuel Injection systems? Have you debugged before
Not good, never debugged one yet.... but would like too...
GBR8465 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Road King & 1200RT Contrasted Nodakgus RT Series 15 Jan 2nd, 2007 5:27 pm
Dead Rabbit along the side of the road. norsseman Humor 0 Oct 19th, 2006 9:45 pm
My road trip so far.. sanjaun2 Ride Tales 19 Sep 21st, 2006 2:56 pm
On the road again... CoolDaddy Bike Talk 3 Aug 28th, 2006 11:00 pm
New K1200GT to debut in US at Long Beach IMS eljeffe K1200/1300GT (The Next Generation) 1 Nov 17th, 2005 7:11 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome